Package Details: gitstats-git 293.e35fea2-1

Git Clone URL: https://aur.archlinux.org/gitstats-git.git (read-only, click to copy)
Package Base: gitstats-git
Description: A statistics generator for git repositories.
Upstream URL: http://gitstats.sourceforge.net
Licenses: GPL3
Submitter: the_isz
Maintainer: hcartiaux
Last Packager: the_isz
Votes: 68
Popularity: 0.29
First Submitted: 2010-03-06 20:42
Last Updated: 2015-10-16 17:44

Latest Comments

« First ‹ Previous 1 2

the_isz commented on 2011-10-14 21:36

matthiaskrgr, could this have been a temporary problem with github or your
connection? Because the package built flawlessly for me...

Could you try deleting the src and pkg directories, then running makepkg again?

the_isz commented on 2011-10-14 14:01

Thanks for the hint, will check it out tomorrow.

matthiaskrgr commented on 2011-10-14 13:44

makepkg
==> Determining latest git revision...
-> Version found: 20111014
==> Making package: gitstats-git 20111014-1 (Fri Oct 14 15:44:10 CEST 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
==> Connecting to GIT server....
Cloning into gitstats...
fatal: The remote end hung up unexpectedly
==> ERROR: A failure occurred in build().
Aborting...

the_isz commented on 2011-02-01 21:08

Thanks for giving me the hint, I think the new PKGBUILD should fix this problem.

notizblock commented on 2011-02-01 13:59

the first line of gitstats needs to be changed to:
/usr/bin/env python2

notizblock commented on 2011-02-01 13:41

File "/usr/bin/gitstats", line 47
print '>> ' + ' | '.join(cmds),
^
SyntaxError: invalid syntax

Anonymous comment on 2010-11-30 14:58

Please update the PKGBUILD so that the dependency and the interpreter are python2. Thanks.