Package Details: gitit 0.13.0.0-1

Git Clone URL: https://aur.archlinux.org/gitit.git (read-only, click to copy)
Package Base: gitit
Description: A wiki backed by a git, darcs, or mercurial filestore
Upstream URL: https://hackage.haskell.org/package/gitit
Keywords: darcs git gitit haskell mercurial wiki
Licenses: GPL
Submitter: Rufflewind
Maintainer: Rufflewind
Last Packager: Rufflewind
Votes: 7
Popularity: 0.68
First Submitted: 2015-09-09 08:23
Last Updated: 2020-11-17 06:53

Required by (0)

Sources (198)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

27cb33fa commented on 2018-05-28 09:22

Hello,

This package doesn't install correctly on a clean installation of ArchLinux. The following message is displayed:

==> Starting build()...
Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: gitit-0.12.2.1 (user goal)
[__1] trying: xss-sanitize-0.3.5.7 (dependency of gitit)
[__2] trying: attoparsec-0.13.2.2 (dependency of xss-sanitize)
[__3] trying: scientific-0.3.5.2 (dependency of attoparsec)
[__4] trying: integer-logarithms-1.0.2 (dependency of scientific)
[__5] next goal: base (dependency of gitit)
[__5] rejecting: base-4.11.1.0/installed-4.1... (conflict: integer-logarithms
=> base>=4.3 && <4.11)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: gitit, attoparsec, base,
integer-logarithms, scientific, xss-sanitize
Note: when using a sandbox, all packages are required to have consistent
dependencies. Try reinstalling/unregistering the offending packages or
recreating the sandbox.

cidig commented on 2018-02-07 10:53

@Rufflewind: It worked! Thank you!

Rufflewind commented on 2018-02-04 17:57

@cidig: Try the latest PKGBUILD and let me know if it fixes your problem. If your problem is not resolved, please paste all the errors from the build process.

cidig commented on 2018-02-04 13:43

I get this error when trying to install.

cabal: Error: some packages failed to install: ConfigFile-1.1.4-DJARwklgWmZ58CrBTu3gLb depends on ConfigFile-1.1.4 which failed to install. MissingH-1.4.0.1-LiDMbW8CWXsHQNp7pRLfLQ failed during the building phase. The exception was: ExitFailure 1 gitit-0.12.2.1-2LitgTkNODMB5Zyxj3ms3b depends on gitit-0.12.2.1 which failed to install.

DkTyph commented on 2017-09-14 16:43

Thank you!!

Rufflewind commented on 2017-09-14 06:37

@DkTyph: Thanks! I've pushed an update to fix this.

DkTyph commented on 2017-09-13 18:34

Resulting binary has the following error:

gitit: /home/dk/.cache/pacaur/gitit/src/gitit-0.12.2.1/.stack-work/install/x86_64-linux-ncurses6-nopie/lts-8.0/8.0.2/share/x86_64-linux-ghc-8.0.2/gitit-0.12.2.1/data/default.conf: openFile: does not exist (No such file or directory)

Rufflewind commented on 2017-08-31 18:58

@solnce: Arch recently removed static libraries, which makes it very difficult to build statically linked executables using Cabal. I switched to Stack, which is immune to these problems. The rationale is explained in more detail here: https://aur.archlinux.org/cgit/aur.git/commit/PKGBUILD?h=gitit&id=98e9e09c6e3ca234bca6411f000fafad2c6087df

If the weight of stack as a dependency is a concern, you can try this instead: https://aur.archlinux.org/packages/stack-bin

solnce commented on 2017-08-31 07:41

Why has the stack dependency been introduced in the latest version? This will install 180 haskell related packages on my system.

Rufflewind commented on 2016-12-16 22:25

@ftschindler: I've bumped the version. Let me know if it still doesn't work.