Package Details: github-notify 0.1.2.1-1

Git Clone URL: https://aur.archlinux.org/github-notify.git (read-only, click to copy)
Package Base: github-notify
Description: GitHub notification notifier
Upstream URL: https://www.github.com/Xandaros/GithubNotify
Licenses: custom
Submitter: Xandaros
Maintainer: Xandaros
Last Packager: Xandaros
Votes: 3
Popularity: 0.000000
First Submitted: 2015-05-16 18:57
Last Updated: 2016-07-19 06:11

Latest Comments

milk commented on 2019-01-08 05:26

currently getting;


Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: GithubNotify-0.1.2.1 (user goal)
[__1] next goal: base (dependency of GithubNotify)
[__1] rejecting: base-4.12.0.0/installed-4.1... (conflict: GithubNotify =>
base>=4.8 && <4.10)
[__1] rejecting: base-4.12.0.0, base-4.11.1.0, base-4.11.0.0, base-4.10.1.0,
base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0,
base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1,
base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0,
base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0,
base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from
non-upgradeable package requires installed instance)
[__1] fail (backjumping, conflict set: GithubNotify, base)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, GithubNotify
Note: when using a sandbox, all packages are required to have consistent
dependencies. Try reinstalling/unregistering the offending packages or
recreating the sandbox.

==> ERROR: A failure occurred in build().
    Aborting...

Xandaros commented on 2016-07-15 11:45

There you go - the dependency errors should be fixed now.

Btw, technically this is an upstream problem - the dependencies were set in such a way that they were incompatible with GHC 8. I just happen to also be upstream :P

ptkato commented on 2016-07-14 18:15

I'm confused, getting dependency errors:

Resolving dependencies...
cabal: Could not resolve dependencies:
trying: GithubNotify-0.1.0.0 (user goal)
next goal: base (dependency of GithubNotify-0.1.0.0)
rejecting: base-4.9.0.0/installed-4.9... (conflict: GithubNotify => base>=4.8 && <4.9)
rejecting: base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0,
base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0,
base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0,
base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0,
base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires installed instance)
Dependency tree exhaustively searched.

==> ERROR: A failure occurred in build().
Aborting...
:: failed to build github-notify package(s)

awilliamson commented on 2015-05-17 18:07

PKGBUILD requires 'cabal update' to be ran, otherwise building will fail as package list for hackage.haskell.org doesn't exist.