Package Details: github-desktop 2.3.1-1

Git Clone URL: https://aur.archlinux.org/github-desktop.git (read-only, click to copy)
Package Base: github-desktop
Description: GUI for managing Git and GitHub.
Upstream URL: https://desktop.github.com
Keywords: git github
Licenses: MIT
Submitter: mikelpint
Maintainer: immackay
Last Packager: immackay
Votes: 23
Popularity: 0.095029
First Submitted: 2017-07-22 21:26
Last Updated: 2020-02-18 07:29

Pinned Comments

immackay commented on 2019-04-26 06:43

Recommendation: install the binary version, github-desktop-bin.

Compiling this is painful.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

xgdgsc commented on 2018-04-10 09:20

python2 should be a makedep

pheoxy commented on 2018-04-10 07:36

github-desktop builds fine on latest within a virtualbox vm though. Would make flags in /etc/makepkg.conf be affecting it?

pheoxy commented on 2018-04-09 14:00

ERROR: A failure occurred in build().

https://pastebin.com/TdaBK7f9

On:

cd app && yarn install --force && cd .. && git submodule update --recursive --init && yarn compile:tslint

"node-gyp cannot find module"

Hope this helps I'm getting the same error as @sl1pkn07

immackay commented on 2018-04-08 10:22

sl1pkn07, you shouldn't have to use any sort of patch for npm to install this. If you want me to troubleshoot, you're going to have to provide more than the vague console log that yarn produces.

Why did you modify your system's electron to get rid of gnome-keyring? These are requirements to build this package. Or am I reading what you wrote correctly?

sl1pkn07 commented on 2018-04-07 19:58

ok, fixed in my side with this patch in npm package https://patch-diff.githubusercontent.com/raw/npm/npm/pull/20276.diff

but now the big problem is, i can't able to use system electron (modified by me for get rid gnome keyring)

always download and use electron 1.8.3 form electron site

Packaging… Packaging app for platform linux x64 using electron v1.8.3

how i can use/link github-desktop with system electron?

greetings

sl1pkn07 commented on 2018-04-05 18:46

https://pastebin.com/NV4pUh9u https://pastebin.com/STuC6j0C

but npm and node-gyp (for the file node-gyp.js) is installed

kolik29 commented on 2018-02-14 18:55

System freezes when installed. Logs: https://pastebin.com/777Q0Tir mb @OriginCode meant it

immackay commented on 2018-01-31 05:41

@azhang66 should be fixed, I'll add that to the -git package as well. Thanks for pointing that out, jokes on me for never using icons I suppose.

@OriginCode can you provide more information?

OriginCode commented on 2018-01-28 10:52

It is stuck when building through yarn. I just saw this: [-/5] . waiting...

azhang66 commented on 2018-01-21 07:07

@immackay, a few things need to be fixed with regards to the icon and desktop files.

In the PKGBUILD, the desktop file and icons should be installed with permissions 0644; the install -D ... should be replaced with install -Dm644 ...

In the github-desktop.desktop file, the Icon field references an icon named desktop, but the PKGBUILD installs the icons as github-desktop. The Icon filed needs to read github-desktop rather than desktop