Package Details: gitg-git 3.30.1.r171.gd3855352-1

Git Clone URL: https://aur.archlinux.org/gitg-git.git (read-only, click to copy)
Package Base: gitg-git
Description: A GIT repository viewer based on GTK+ - git checkout
Upstream URL: https://gitlab.gnome.org/GNOME/gitg/
Licenses: GPL
Conflicts: gitg
Provides: gitg
Submitter: mrspin
Maintainer: pretzelca
Last Packager: pretzelca
Votes: 24
Popularity: 0.44
First Submitted: 2009-02-07 16:47
Last Updated: 2019-08-22 07:54

Latest Comments

1 2 3 Next › Last »

yakusha commented on 2020-01-04 23:48

There might be an error if your locale is Turkish?

"FAILED: libgitg/Gitg-1.0.typelib /usr/bin/g-ir-compiler --shared-library libgitg-1.0 --output libgitg/Gitg-1.0.typelib /var/tmp/pamac-build-sabri/gitg-git/src/build/libgitg/Gitg-1.0.gir

(g-ir-compiler:26582): ERROR : 02:40:23.441: Invalid typelib for module 'Gitg': In directory (Context: AuthenticationLifeTime)): The value contains invalid characters: 'sessıon'

[189/199] Linking target tests/tests-progress-bin.

[190/199] Linking target tests/tests-diff-view.

[191/199] Linking target tests/tests-repository-list-box.

[192/199] Linking target libgitg-ext/libgitg-ext-1.0.so.0.0.0.

[193/199] Linking target tests/libgitg/tests-libgitg.

ninja: build stopped: subcommand failed. "

pretzelca commented on 2019-08-22 07:07

I've gone ahead and have adopted this package, just let me know if there are any issues building and I'll try to fix them within a couple of hours.

albfan commented on 2019-07-25 14:32

libgd is not needed anymore

albfan commented on 2019-07-25 14:31

this needs libdazzle as dependency

albfan commented on 2019-07-25 14:29

The first reachable tag from master is not the last one. I think is better to use:

pkgver() {
  cd $srcdir/build
  PROJECT_VERSION="$(meson introspect --projectinfo | jq -r .version)"
  cd ../../$pkgname
  GIT_HEAD_SHA="$(git rev-parse --short HEAD)"
  printf "%s_%s" "$PROJECT_VERSION" "$GIT_HEAD_SHA"
}

which shows the meson project version and the sha for the commit used to build

This needs jq as makedependency

donny commented on 2015-09-23 18:34

Probably git://git.gnome.org/libgd should be written in $source array.

amdj commented on 2015-05-26 07:38

Misses gobject-introspection and webkit2gtk as dependency.

eworm commented on 2015-03-04 09:06

autoconf belongs to base-devel group and is expected to be installed.

nebulon commented on 2015-03-04 08:49

Misses autoconf as dependency.

rafi commented on 2014-06-25 15:22

Missing dependency: `libpeas`
Also, had to install `libgit2-git` and `libgit2-glib-git` to satisfy dependency version requirements.