Package Details: git-nautilus-icons 2.0.0-4

Git Clone URL: https://aur.archlinux.org/git-nautilus-icons.git (read-only, click to copy)
Package Base: git-nautilus-icons
Description: A Nautilus, Nemo, and Caja extension to overlay icons on files in git repositories
Upstream URL: https://github.com/chrisjbillington/git-nautilus-icons
Licenses: BSD 2-Clause "Simplified"
Conflicts: git-caja-icons, git-nautilus-icons-common, git-nemo-icons
Replaces: git-caja-icons, git-nautilus-icons-common, git-nemo-icons
Submitter: chrisjbillington
Maintainer: chrisjbillington
Last Packager: chrisjbillington
Votes: 3
Popularity: 0.036423
First Submitted: 2019-08-31 16:59
Last Updated: 2020-05-26 20:35

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

chrisjbillington commented on 2020-05-26 20:37

I thought the official advice was to include transitive dependencies that you also use directly. But I realise now it's ambiguous. Does "don't rely on transitive dependencies" mean "don't rely on them being installed, make sure you depend on them directly", or does it mean "don't add them as direct dependencies"? I always assumed the former, but now I'm getting the impression the latter is intended.

Anyway, removed it.

yochananmarqos commented on 2020-05-26 20:28

Looks good to me. Howver, it's redundant to specify python-setuptools as python-setuptools-scm depends on it.

chrisjbillington commented on 2020-05-26 20:25

Ok, should be better now, thanks for your suggestions!

chrisjbillington commented on 2020-05-26 20:22

I meant I would modify the PKGBUILD for git-nautilus-icons-git, but I see you have beaten me to it

yochananmarqos commented on 2020-05-26 20:15

You don't need to add the -git packages as they already provide and conflict with the main packages.

chrisjbillington commented on 2020-05-26 20:11

Ah, thanks re. nemo!

I'll add the extra conflicts too, also to the -git package

yochananmarqos commented on 2020-05-26 19:50

It's nemo-python, not python-nemo. ;)

You're missing the conflicts array. This also needs to conflict with and replace git-nautilus-icons-common:

conflicts=("$pkgname-common"
          'git-caja-icons'
          'git-nemo-icons')
replaces=("$pkgname-common"
          'git-caja-icons'
          'git-nemo-icons')