Package Details: girara-git 0.2.8.r44.g17f58c6-1

Git Clone URL: https://aur.archlinux.org/girara-git.git (read-only)
Package Base: girara-git
Description: user interface library
Upstream URL: http://pwmt.org/projects/girara
Licenses: custom
Conflicts: girara
Provides: girara
Submitter: mlq
Maintainer: mlq
Last Packager: mlq
Votes: 78
Popularity: 0.000000
First Submitted: 2014-06-26 07:01
Last Updated: 2018-03-14 10:51

Latest Comments

1 2 3 Next › Last »

Awebb commented on 2017-01-30 07:39

@HisDudeness: Read the AUR and PKGBUILD wiki pages. The group base-devel is supposed to be installed, when working with the AUR.

EDIT: To be more clear, packages from base and base-devel are not supposed to end up in the dep arrays of a PKGBUILD.

HisDudeness commented on 2017-01-27 09:11

gcc is not listed as a dependency, but if you try to install girara-git without gcc on your system, it tells you

make: cc: Command not found
make: *** [Makefile:126: /tmp/yaourt-tmp-dude/aur-girara-git/release/girara/callbacks.o] Error 127
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build girara-git.

Alad commented on 2016-04-11 11:29

This is perfectly normal, see:

https://wiki.archlinux.org/index.php/VCS_package_guidelines

Z2h-A6n commented on 2016-02-01 23:43

Looks like the package version should be updated in the PKGBUILD. The most recent version of the source (0.2.5) is downloaded from git, but the version is still listed as 0.2.4

Changing the pkgver= line in the PKGBUILD to the most recent version fixed this for me.

Awebb commented on 2015-05-06 08:36

girara-git currently builds with libnotify turned on, no matter if libnotify is present or not. You should either add it to the dep array, patch the makefile (according to the Readme, libnotify is optional), or check with upstream, why this happens. If you don't have the time for upstream work, I will.

mlq commented on 2014-07-07 17:06

girara-gtk3-git does not exist any more and should be replaced with girara-git since we do not support GTK2 any longer

kozaki commented on 2014-07-07 16:38

Hi, does girara-git conflict with "girara-gtk3-git"?

misc commented on 2014-04-16 11:27

source line should contain #branch=develop.

misc commented on 2014-01-03 10:17

If this is the git package, shouldn't it follow the develop branch?

niklasni1 commented on 2012-09-01 13:41

Should add gettext to the build dependencies, this needs msgfmt(1) which is part of that package.