Package Details: gimp-git 2:2.99.1.r5186.7f95abc4ef-1

Git Clone URL: https://aur.archlinux.org/gimp-git.git (read-only, click to copy)
Package Base: gimp-git
Description: GNU Image Manipulation Program
Upstream URL: https://www.gimp.org
Licenses: GPL, LGPL
Conflicts: gimp
Provides: gimp
Submitter: None
Maintainer: bartus
Last Packager: bartus
Votes: 113
Popularity: 0.44
First Submitted: 2009-05-27 08:12
Last Updated: 2020-09-27 18:08

Dependencies (56)

Required by (151)

Sources (2)

Pinned Comments

bartus commented on 2019-08-01 19:45

Note: If you wont to have both gimp-git and stock gimp installed, there's a non-conflicting version of this package called gimp-develop-git
This package is also hosted on GitHub.
Disclaimer: Package uses Travis to automatically update version of dependencies. Script executes once a day, so please wait a day before reporting dependencies version mismatch, thanks!

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

electricprism commented on 2018-10-06 23:08

AFAIK on GIMP's roadmap they say GTK3 is in master, is it possible to patch the PKGBUILD to request building the GTK3 version (assuming this version is not GTK3)

bartus commented on 2018-09-19 06:12

@FFY00; there is one, but it's old as balls ;)

FFY00 commented on 2018-09-18 19:31

There's no gimp-devel. As I said, it would need to be created.

alex-y commented on 2018-09-18 18:14

Where is gimp-devel???

FFY00 commented on 2018-09-18 16:54

I will not patch the build so that it doesn't conflict with gimp, that's not the point of -git packages. For that you should create a gimp-devel package IIRC. I probably can fix the gimptool situation but I'm not sure, need to ask the other guys.

bartus commented on 2018-09-18 13:50

@FFY00: few more notes apropos package() function:

  • gimptool-2.0 doesn't exist in gimp-git package (there is gimptool-2.99, which is required only for building gimp plugins, but those in turn uses gimptool-2.0 explicitly, so there is no need for making this symlink at all).
  • linux.gpl should be installed in /usr/share/gimp/2.99/palettes/.
  • gimp.desktop should be renamed to gimp-2.99.desktop along with it icons.
  • metainfo can be safely removed as it contains only freedesktop.appstream metadate witch even doesn't reflects content of the gimp-git package.
  • Those in turns makes gimp-git nonconflicting with gimp. Until, of curse, version 2.99 gets into main repo, but until then we should have gimp-3.0 in master, I hope ;)

PKGBUILD.patch

rogers commented on 2018-09-18 09:00

It's using api_version instead of gimp_version. 192.168.0.1 https://19216801help.com/

bartus commented on 2018-09-16 10:38

@FFY00: for a sec, I realy fought that 3.0 was released... then, sadly realised that you are using api_version instead of gimp_version, mild trolling perhaps ;)

FFY00 commented on 2018-09-15 15:02

It should be working now. Both gimp-git, gegl-git and babl-git are now following this format.

bartus commented on 2018-09-14 19:20

@FFYOO: You are somewhat right. But consider someone having local repository including gimp-git (which I have, for all machines in my local newtork). Without correct pkgver succession pacman -Suy won't work as it can't determine if the repository version of a package is newer than local. Automatic rebuild script also fails without correct pkgver to trigger rebuild. paccache -r -k1 also fails as it relays on pacsort ability to order cached files according to version string. this renders my setup broken for gimp-git ;)

If you look at PKBUILD guidelines for VCS there is nr.commit in pkgver string. Right between actual version string and commit hash. PKGBUILD-VCS@archwiki