Package Details: gimp-devel 1:2.10.0-1

Git Clone URL: https://aur.archlinux.org/gimp-devel.git (read-only, click to copy)
Package Base: gimp-devel
Description: GNU Image Manipulation Program (Development version)
Upstream URL: http://www.gimp.org/
Licenses: GPL, LGPL
Conflicts: gimp
Provides: gimp=2.10.0
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 12
Popularity: 0.000003
First Submitted: 2017-02-02 23:39
Last Updated: 2018-04-30 18:09

Dependencies (36)

Required by (144)

Sources (2)

Latest Comments

« First ‹ Previous 1 2

SinClaus commented on 2017-12-15 02:40

Yes, I can modify, but developer think something when say about dependencies.

maderios commented on 2017-12-14 14:14

@SinClaus You have to modify dependencies in PKGBUILD. I built gimp-devel 2.9.8 with babl-git and gegl-git. It works fine.

twa022 commented on 2017-12-14 14:01

@SinClaus: the pkgver for babl-git and gegl-git will be updated at build time. Build and install those packages in that order, them gimp-devel. If you feel comfortable editing the official babl and gegl PKGBUILDs, both required versions have been released by developers just not yet packaged by the arch packagers yet.

SinClaus commented on 2017-12-14 13:46

Fuck!!! Where are babl and gegl? In the git repo we have gegl-git 0.3.20.13-1. Why gimp is released without them?

twa022 commented on 2017-12-14 01:50

My 2.9.8 build successfully loads the python plugins - let me know if you experience errors. You may need to remove ~/.config/GIMP/2.9/pluginrc -- I got this error on 2.9.6 to 2.9.8 upgrade: GIMP-Error: Skipping '/home/<username>/.config/GIMP/2.9/pluginrc': wrong pluginrc file format version.</username>

twa022 commented on 2017-12-13 04:13

Gimp 2.9.8 requires babl>=0.1.38 and gegl>=0.3.24. You will need to build those packages yourself until official repos are updated to latest versions. Or build babl-git and gegl-git from AUR.

misanthropist commented on 2017-09-28 20:39

@therealfarfetchd I have the same problem, and your workaround almost did the trick, but I had to change /usr/lib/gimp/2.0/plug-ins/*.py to /usr/lib/gimp/2.0/plug-ins/**/*.py to include .py files in subdirectories as well.

2xsaiko commented on 2017-09-28 20:07

For some reason, /usr/bin/env doesn't want to find python2 when loading GIMP, so the python interpreter isn't available.

Here's a workaround:

for file in /usr/lib/gimp/2.0/plug-ins/*.py; do sed -i 's|#! */usr/bin/env python2|#!/usr/bin/python2|' "$file"; done

Does anyone else have this problem?

donny commented on 2017-08-11 18:21

Missing build dependencies: libraw lensfun suitesparse

fightcookie commented on 2017-03-01 03:24

Please change the url of the source and the upstream url to the TLS encrypted https variant! thanks :)