Package Details: gimp-dds 3.0.1-6

Git Clone URL: https://aur.archlinux.org/gimp-dds.git (read-only)
Package Base: gimp-dds
Description: A plugin for the GIMP version 2.8. It allows you to load and save images in the Direct Draw Surface (DDS) format
Upstream URL: https://code.google.com/archive/p/gimp-dds
Keywords: dds gimp
Licenses: GPL2
Submitter: Megameneer
Maintainer: fshp
Last Packager: fshp
Votes: 26
Popularity: 1.974236
First Submitted: 2015-09-04 18:43
Last Updated: 2018-06-03 21:08

Latest Comments

« First ‹ Previous 1 2

Razende commented on 2018-05-13 20:19

So I heard gimp-dds still works on 2.10. At least on Windows.

I'm just getting this error when trying to install it.

I'm still a Linux noob so no idea if this can be fixed, it would be nice :)

==> gimp-dds dependencies: - gimp>=2.8.x (already installed) - glib2 (already installed) - gtk2 (already installed) - pango (already installed) - atk (already installed) - pkg-config (already installed) [makedepend]

==> Continue building gimp-dds ? [Y/n] ==> ---------------------------------- ==> y

==> Building and installing package ==> Making package: gimp-dds 3.0.1-5 (zo 13 mei 2018 21:26:06 CEST) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading gimp-dds-3.0.1.tar.bz2... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 2 459k 2 9770 0 0 43230 0 0:00:10 --:--:-- 0:00:10 4303100 459k 100 459k 0 0 1480k 0 --:--:-- --:--:-- --:--:-- 1475k ==> Validating source files with md5sums... gimp-dds-3.0.1.tar.bz2 ... Passed ==> Validating source files with sha256sums... gimp-dds-3.0.1.tar.bz2 ... Passed ==> Extracting sources... -> Extracting gimp-dds-3.0.1.tar.bz2 with bsdtar ==> Starting build()... Package gegl-@GEGL_MAJOR_MINOR_VERSION@ was not found in the pkg-config search path. Perhaps you should add the directory containing gegl-@GEGL_MAJOR_MINOR_VERSION@.pc' to the PKG_CONFIG_PATH environment variable Package 'gegl-@GEGL_MAJOR_MINOR_VERSION@', required by 'gimp-2.0', not found Package gegl-@GEGL_MAJOR_MINOR_VERSION@ was not found in the pkg-config search path. Perhaps you should add the directory containinggegl-@GEGL_MAJOR_MINOR_VERSION@.pc' to the PKG_CONFIG_PATH environment variable Package 'gegl-@GEGL_MAJOR_MINOR_VERSION@', required by 'gimp-2.0', not found [CC]\tcolor.c Package gegl-@GEGL_MAJOR_MINOR_VERSION@ was not found in the pkg-config search path. Perhaps you should add the directory containing gegl-@GEGL_MAJOR_MINOR_VERSION@.pc' to the PKG_CONFIG_PATH environment variable Package 'gegl-@GEGL_MAJOR_MINOR_VERSION@', required by 'gimp-2.0', not found Package gegl-@GEGL_MAJOR_MINOR_VERSION@ was not found in the pkg-config search path. Perhaps you should add the directory containinggegl-@GEGL_MAJOR_MINOR_VERSION@.pc' to the PKG_CONFIG_PATH environment variable Package 'gegl-@GEGL_MAJOR_MINOR_VERSION@', required by 'gimp-2.0', not found [CC]\tdds.c dds.c:27:10: fatal error: gtk/gtk.h: No such file or directory #include <gtk gtk.h=""> ^~~~~~~~~~~ compilation terminated. make: *** [Makefile:42: dds.o] Error 1 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build gimp-dds. ==> Restart building gimp-dds ? [y/N] ==> ---------------------------------</gtk>

Razende commented on 2018-05-13 14:57

Oh ok, I didn't know. So they were talking about 2.10 already back in 2013, while it just came out.

fshp commented on 2018-05-13 14:46

Its old roadman. See here: https://code.google.com/archive/p/gimp-dds/source/default/commits

skirst@gmail.com Dec 7, 2013 240 * Initial porting work for GIMP 2.9/2.10 complete

2013 year

Razende commented on 2018-05-13 14:41

@fshp Well we will see, at least they updated the roadmap. I have good hope :P

fshp commented on 2018-05-13 14:12

The last changes were in 2013. Version 4 will not be.

Razende commented on 2018-05-13 14:06

Looks like it doesn't support Gimp 2.10 yet. But its on the roadmap :)

4.x will be the next major version of the plugin. New features will include: * GIMP 2.9/2.10 support * 16 and 32-bit integer/floating point image support.

electricprism commented on 2016-09-17 21:15

I have to edit out dep - gimp as I use gimp-git and gimp-gtk3-git to build.

Megameneer commented on 2015-10-07 12:09

@sowieso: I just fixed it using your suggestions. Thanks for your efforts!

sowieso commented on 2015-10-04 11:10

Tried to get it running, but as far as I understand, you copy the plugin to the wrong location. Here is my fixed package() that works for me (/usr/lib instead of /usr/share):

package() {
cd "$srcdir"/gimp-dds-"$pkgver"
install -dm755 "$pkgdir"/usr/lib/gimp/2.0/plug-ins/
cp dds "$pkgdir"/usr/lib/gimp/2.0/plug-ins
chmod 755 "$pkgdir"/usr/lib/gimp/2.0/plug-ins/dds
}