Package Details: ghc8.2 8.2.2-1

Git Clone URL: https://aur.archlinux.org/ghc8.2.git (read-only)
Package Base: ghc8.2
Description: Legacy GHC (8.2 series). Originally released on July 2017.
Upstream URL: http://www.haskell.org/ghc/
Licenses: custom
Provides: haskell-array=0.5.2.0, haskell-base=4.10.1.0, haskell-binary=0.8.5.1, haskell-bytestring=0.10.8.2, haskell-cabal=2.0.1.0, haskell-containers=0.5.10.2, haskell-deepseq=1.4.3.0, haskell-directory=1.3.0.2, haskell-filepath=1.4.1.2, haskell-ghc-boot=8.2.2, haskell-ghc-boot-th=8.2.2, haskell-ghc-compact=0.1.0.0, haskell-ghc-prim=0.5.1.1, haskell-haskeline=0.7.4.0, haskell-hoopl=3.10.2.2, haskell-hpc=0.6.0.3, haskell-integer-gmp=1.0.1.0, haskell-pretty=1.1.3.3, haskell-process=1.6.1.0, haskell-template-haskell=2.12.0.0, haskell-terminfo=0.4.1.0, haskell-time=1.8.0.2, haskell-transformers=0.5.2.0, haskell-unix=2.7.2.2, haskell-xhtml=3000.2.2
Replaces: ghc8.2-bin, haskell-array, haskell-base, haskell-binary, haskell-bytestring, haskell-cabal, haskell-containers, haskell-deepseq, haskell-directory, haskell-filepath, haskell-ghc-boot, haskell-ghc-boot-th, haskell-ghc-compact, haskell-ghc-prim, haskell-haskeline, haskell-hoopl, haskell-hpc, haskell-integer-gmp, haskell-pretty, haskell-process, haskell-template-haskell, haskell-terminfo, haskell-time, haskell-transformers, haskell-unix, haskell-xhtml
Submitter: rudy.matela
Maintainer: rudy.matela
Last Packager: rudy.matela
Votes: 0
Popularity: 0.000000
First Submitted: 2018-05-31 16:35
Last Updated: 2018-05-31 16:35

Required by (287)

Sources (1)

Latest Comments

rudy.matela commented on 2018-11-28 22:00

@popsch The circular dependency is intentional. You need ghc-8.2 to be able to compile ghc-8.2 (or at the very least ghc-8.0).

This is explained in a comment on the PKGBUILD itself:

# This can be built by using GHC 8.2, this is noted by the apparent circular
# dependency on ghc8.2.  A binary version is provided by the AUR ghc8.2-bin
# package.

You can install the binary version provided by the ghc8.2-bin then use it to compile this.

popsch commented on 2018-11-28 15:33

The package currently has a circular dependency.

/tmp$ cower -d ghc8.2
cd:: ghc8.2 downloaded to /tmp
/tmp$ cd ghc8.2/
/tmp/ghc8.2$ ls
ghc.install  PKGBUILD
/tmp/ghc8.2$ makepkg
==> Making package: ghc8.2 8.2.2-1 (Wed 28 Nov 2018 10:25:51 AM EST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Missing dependencies:
  -> ghc8.2
==> ERROR: Could not resolve all dependencies.