Package Details: gettext-git 0.21.r12.ge645b7d56-1

Git Clone URL: https://aur.archlinux.org/gettext-git.git (read-only, click to copy)
Package Base: gettext-git
Description: GNU internationalization library
Upstream URL: https://www.gnu.org/software/gettext/
Licenses: GPL3
Conflicts: gettext
Provides: gettext
Submitter: Chocobo1
Maintainer: Chocobo1
Last Packager: Chocobo1
Votes: 0
Popularity: 0.000000
First Submitted: 2017-08-13 18:55
Last Updated: 2020-09-05 17:49

Required by (378)

Sources (2)

Latest Comments

Chocobo1 commented on 2020-09-05 17:53

Please avoid pull git submodules recursively. Users who build other packages which use gnulib may benefit from already having it in SRCDEST-directory.

OK done, however I really dislike this way as it add more maintenance burden, therefore I would only change it upon request.

haawda commented on 2020-09-05 16:56

Please avoid pull git submodules recursively. Users who build other packages which use gnulib may benefit from already having it in SRCDEST-directory.

# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>

pkgname=gettext-git
pkgver=0.21.r12.ge645b7d56
pkgrel=1
pkgdesc="GNU internationalization library"
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/gettext/"
license=('GPL3')
depends=('glibc' 'glib2' 'gperf' 'libunistring' 'ncurses')
makedepends=('git' 'fpc' 'grep' 'help2man' 'wget' 'xz')
provides=('gettext')
conflicts=('gettext')
source=("git+https://git.savannah.gnu.org/git/gettext.git" git://git.sv.gnu.org/gnulib)
sha256sums=('SKIP' 'SKIP')

prepare() {
  cd "gettext"
  git submodule init
  git config submodule.gnulib.url ../gnulib
  git submodule update
}

pkgver() {
  cd "gettext"

  git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}

build() {
  cd "gettext"

  ./autogen.sh
  ./configure \
    --prefix="/usr" \
    --without-gettext-tools
  make maintainer-update-po-local
}

check() {
  cd "gettext"

  make check
}

package() {
  cd "gettext"

  make DESTDIR="$pkgdir" install
}

Chocobo1 commented on 2020-07-29 13:59

I needed to install fpc, the Free Pascal Compiler, to build.

Fixed, thanks!

haawda commented on 2020-07-29 13:29

I needed to install fpc, the Free Pascal Compiler, to build.