Package Details: get_iplayer 3.22-1

Git Clone URL: https://aur.archlinux.org/get_iplayer.git (read-only)
Package Base: get_iplayer
Description: Allows you to download or stream any iPlayer programme from the BBC in H.264 (Quicktime/mp4) format, any radio programmes in MP3 or RealAudio format
Upstream URL: http://www.infradead.org/get_iplayer/html/get_iplayer.html
Keywords: bbc internet iplayer multimedia radio tv
Licenses: GPL3
Submitter: Sacro
Maintainer: alexmerry
Last Packager: alexmerry
Votes: 99
Popularity: 0.015137
First Submitted: 2008-10-09 03:05
Last Updated: 2019-08-19 21:48

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

bananabrain commented on 2011-05-08 19:54


Seems to be broken again:

--
$get_iplayer
Can't locate HTML/Entities.pm in @INC (@INC contains: /usr/lib/perl5/site_perl
/usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl
/usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/bin/get_iplayer line 59.

BEGIN failed--compilation aborted at /usr/bin/get_iplayer line 59.
--

Is this related to psychedelicious' post below?

Anonymous comment on 2011-05-06 13:52

I've changed this package to the _official_ release. GIT version is now separate package get_iplayer-git https://aur.archlinux.org/packages.php?ID=48774

psychedelicious commented on 2011-04-29 02:41

This needs updating, the BBC flash player url has changed

loafer commented on 2011-03-20 20:04

Thanks for the explanation canton7.

canton7 commented on 2011-03-20 20:02

With *-git packages, makepkg automatically ups the pkgver in the PKGBUILD you downloaded to match the current date, which is why you see 20110320 (today's date) as the installed version.
Following your logic, the pkgver in the AUR's PKGBUILD would have to be increased daily, which is obviously impractical.
In fact, the latest git revision will be installed whatever the pkgver, which implies that the pkgver only needs to be incrased when something major happens upstream.

loafer commented on 2011-03-20 19:58

This installs 20110320 not 20110202. The pkgver requires an update.

AshtonBRSC commented on 2011-02-02 20:33

Updated with canton7's PKGBUILD.

canton7 commented on 2011-01-27 12:55

My bad, I was relying on namcap at a point when I didn't fully understand it.

Corrected PKGBUILD: http://pastebin.com/zwbnPp9i

silvik commented on 2011-01-27 11:17

canton7 works, but the dependencies are wrong. replace depends array with the old one:
depends=('perl-libwww' 'perl-html-parser' 'perl-www-mechanize')
also you need to create an "options" file containing "packagemanager AUR" in the build dir.

canton7 commented on 2011-01-09 13:50

Fixed the "running updater to install plugins" error by copying the plugins folder to /usr/share/get_iplayer/plugins
Also setting the packagemanager configuration option to tell get_iplayer not to try and update itself.

PKGBUILD: http://pastebin.com/G2Cp7X6Z
options file: http://pastebin.com/qaD5G4E5