Package Details: gegl-git 0.4.21.r9843.523ababc5-1

Git Clone URL: https://aur.archlinux.org/gegl-git.git (read-only, click to copy)
Package Base: gegl-git
Description: Graph based image processing framework
Upstream URL: https://www.gegl.org
Licenses: GPL3, LGPL3
Conflicts: gegl
Provides: gegl=0.4.21
Submitter: None
Maintainer: bartus (Salamandar)
Last Packager: bartus
Votes: 105
Popularity: 0.000005
First Submitted: 2009-05-27 08:12
Last Updated: 2020-01-26 20:45

Dependencies (35)

Required by (8)

Sources (1)

Pinned Comments

bartus commented on 2019-08-28 15:01

This is a package is also hosted on GitHub.

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

haawda commented on 2018-04-29 11:45

qdii, read the comments. it is quite clear what to do then. Rebuild and install babl-git.

qdii commented on 2018-04-20 00:25

Compilation is broken for me. I get "Requested 'babl >= 0.1.46' but version of babl is 0.1.45". How can I fix that?

bartus commented on 2018-04-11 15:39

@mytbk: deps should be babl>=0.1.46 as extra has babl=0.1.44 which is goint to be pulled instead of aur:babl-git=0.1.46, preventing successful build of gelg-git in clean chroot.

mk-fg commented on 2018-04-07 07:29

Using gegl-git 0.3.30.15-1 without installing its makedepends will give following warnings:

GEGL-Message: 12:16:02.433: Module '/usr/lib/gegl-0.3/matting-levin.so' load error: libumfpack.so.5: cannot open shared object file: No such file or directory

These seem to be non-fatal, but probably indicate that "suitesparse" should be in depends=() instead of makedepends=(), as libumfpack is provided by that one at runtime.

Salamandar commented on 2018-03-06 15:23

Just as Babl, Gegl was ported to Meson :)

cafehaine commented on 2018-03-05 09:51

The correct URL for the git repository is now git://git.gnome.org/browse/gegl

JonnyRobbie commented on 2017-10-22 08:24

Build error.
"Requested 'babl >= 0.1.34' but version of babl is 0.1.33"

Both babl and babl-git are versioned at 0.1.30. The build passes with `babl-git`.

The makedepends should have the git version, the vanilla version fails.

haawda commented on 2017-09-13 22:23

It turns out that the gegl-git package is fine. The culprit was the lensfun-git package from AUR I use, delivering a broken .pc-File for pkg-config.

haawda commented on 2017-09-10 06:32

BTW., I opened a bug report for this: https://bugzilla.gnome.org/show_bug.cgi?id=787475

haawda commented on 2017-09-09 14:34

I need a small patch to compile this.

prepare() {
cd "$srcdir/$_gitname"
patch -p1 < "$srcdir"/correct_lensfun.patch
}

diff --git a/operations/workshop/external/lens-correct.c b/operations/workshop/external/lens-correct.c
index ac8070a3..141ee304 100644
--- a/operations/workshop/external/lens-correct.c
+++ b/operations/workshop/external/lens-correct.c
@@ -19,7 +19,7 @@
*/

#include "config.h"
-#include <lensfun.h>
+#include <lensfun/lensfun.h>
#include <glib/gi18n-lib.h>