Package Details: gcs 4.25.0-1

Git Clone URL: https://aur.archlinux.org/gcs.git (read-only, click to copy)
Package Base: gcs
Description: WYSIWYG editor for building character sheets for GURPS 4th Edition
Upstream URL: https://gurpscharactersheet.com
Licenses: MPL2
Submitter: silverhammermba
Maintainer: AlphaJack
Last Packager: AlphaJack
Votes: 5
Popularity: 0.38
First Submitted: 2014-10-09 16:27
Last Updated: 2020-11-01 11:05

Latest Comments

AlphaJack commented on 2020-09-01 09:54

Starting from 4.12 (Dec 2019) the author publishes a .deb package that can be easily converted to an Arch Linux package.

Program files are now stored under /opt/gcs/

silverhammermba commented on 2018-10-21 22:08

Upstream keeps changing how this is distributed. It's getting harder and harder to make a minimal install that doesn't include its own JVM and I'm just not interested in fighting that any more.

If you want to use the latest GCS, I recommend just downloading the tar from the website and running it from your home directory.

DungeonMaster commented on 2017-04-18 02:25

New version release 4-15-2017. To get it edit the PKGBUILD to read:

pkgver=4.9.0

silverhammermba commented on 2016-09-28 04:53

Just an FYI in case you're wondering why this package just changed so much: gcs used to have some annoying design decisions that made it difficult to conform to the Java packaging guidelines. So previously I fixed this with a patch, which is why the PKGBUILD had to recompile it every update. Thankfully my patch was accepted upstream, so now recompiling is unnecessary. This makes the build process much, much faster.

Also the package now registers gcs's data file types, so it should be possible to double click a .gcs file (or .spl, .adq, .gct, etc.) and have gcs open automatically.

silverhammermba commented on 2016-02-01 19:03

Thanks for letting me know. In the future you can just flag out-of-date and that will better remind me to update the PKGBUILD.

F3nr1s commented on 2016-01-31 14:11

A new version of gcs is finished. If you change in the PKGBUILD file the "pkgver" to 4.3.0, you get the new version.