Package Details: gconf 3.2.6+11+g07808097-6

Git Clone URL: https://aur.archlinux.org/gconf.git (read-only, click to copy)
Package Base: gconf
Description: An obsolete configuration database system
Upstream URL: https://projects-old.gnome.org/gconf/
Licenses: LGPL
Submitter: arojas
Maintainer: yan12125 (lilac)
Last Packager: lilac
Votes: 40
Popularity: 10.53
First Submitted: 2020-01-02 20:47
Last Updated: 2020-01-03 09:41

Required by (454)

Sources (7)

Pinned Comments

flying-sheep commented on 2020-01-06 19:20

Most of the packages that “require” it are actually Electron apps that copy&pasted their dependency lists from elsewhere or failed to update them: Chromium (and subsequently Electron) haven’t been dependent on this for years.

If you want to help, you can ask the maintainers of all those apps if they really still need gconf.

None that I use still need it (spotify and hamsket-bin), and their maintainers removed the superfluous dependency.

yan12125 commented on 2020-01-04 15:18

If you got build issues, please make sure

  1. base-devel group is installed [1]
  2. you are not using a broken AUR helper like pacaur. See https://github.com/E5ten/pacaur/issues/14.

If the build is still not working, use clean chroots [2] to build it.

[1] https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

[2] https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot

Latest Comments

1 2 3 Next › Last »

EltraEden commented on 2020-05-14 13:35

For some reason you need to install manually gobject-introspection package before making gconf otherwise it won't work because of missing M4.

yan12125 commented on 2020-04-03 02:12

@Improvotter: could you paste the command you've run and relevant terminal outputs? I'd like to understand what's going on before making changes.

Improvotter commented on 2020-04-03 00:09

Could you edit line 43 to make it use Python 3.7? Currently gobject-introspection does not support Python 3.8 and this fixes the issue. Otherwise it errors with an ImportError for giscanner.

keithspg commented on 2020-03-26 23:20

Just tried to build this. I do not know if it is temporary or not, but gitlab.gnome.org is not reachable. Had to build gconf-gtk instead.

insane commented on 2020-01-22 12:18

I've had an issue with missing introspection.m4 module while building gconf. It turns out gobject-introspection package was needed, not sure if it's due to my system or its global but it may help for others like me.

src530 commented on 2020-01-13 13:31

aur/gconf 3.2.6+11+g07808097-5 5 -> 6

==> ==> ERROR: unable to update No database errors have been found!

WTF???

frcl commented on 2020-01-11 17:28

Could you add automake as a make dependency? I got the following error message

/usr/bin/gnome-autogen.sh
checking for automake >= 1.9...
  testing automake... not found.
    Aborting...

Of cause installing the automake solved it.

gjvnq commented on 2020-01-11 00:08

You need to install gnome-common from GNOME SVN and make
sure the gnome-autogen.sh script is in your $PATH.
==> ERROR: A failure occurred in prepare().

I think it is running autoconf before installing dependencies. (I am using pacaur by the way)

exdeniz commented on 2020-01-06 22:51

On update 3.2.6+11+g07808097-5 -> 3.2.6+11+g07808097-6 have error:

Switched to a new branch 'makepkg'
==> Starting prepare()...
/home/exdeniz/.cache/yay/gconf/PKGBUILD: line 34: patch: command not found
==> ERROR: A failure occurred in prepare().
    Aborting...
Error making: gconf

UPDATE: [SOLVED] Not installed 'patch' in system.

bpier commented on 2020-01-06 22:17

I get the following error when trying to update using yay:

aclocal: error: couldn't open directory '/usr/local/share/aclocal': No such file or directory

My aclocal is located in /usr/bin/aclocal (owned by automake).

Anything I could do? I couldn’t see any recent changes related to this in either automake or gconf.