Package Details: gconf-sharp-peditors 2.24.4-7

Git Clone URL: https://aur.archlinux.org/gnome-sharp.git (read-only, click to copy)
Package Base: gnome-sharp
Description: Mono bindings for GConf - Property Editing classes
Upstream URL: http://gtk-sharp.sourceforge.net
Licenses: LGPL
Submitter: quequotion
Maintainer: Rogach
Last Packager: Rogach
Votes: 8
Popularity: 1.46
First Submitted: 2017-04-01 18:39
Last Updated: 2020-10-24 08:15

Pinned Comments

quequotion commented on 2019-11-10 09:19

This metapackage has a significant AUR dependency chain. In order to build it in a clean chroot (without using an AUR helper), you will have to preinstall its dependencies and their dependencies (after clean chroot building each of them):

makechrootpkg -c -r $CHROOT \
-I ../libgnomeui/libgnomeui-2.24.5-3-x86_64.pkg.tar.xz \
-I ../libbonoboui/libbonoboui-2.24.5-3-x86_64.pkg.tar.xz \
-I ../libgnome/libgnome-2.32.1-7-x86_64.pkg.tar.xz \
-I ../libgnomecanvas/libgnomecanvas-2.30.3-4-x86_64.pkg.tar.xz \
-I ../libgnome/libgnome-data-2.32.1-7-x86_64.pkg.tar.xz \
-I ../gnome-vfs/gnome-vfs-2.24.4-11-x86_64.pkg.tar.xz \
-I ../gnome-mime-data/gnome-mime-data-2.18.0-8-any.pkg.tar.xz \
-I ../gamin/gamin-0.1.10-9-x86_64.pkg.tar.xz \
-I ../libbonobo/libbonobo-2.32.1-4-x86_64.pkg.tar.xz \
-I ../orbit2/orbit2-2.14.19-7-x86_64.pkg.tar.xz

Latest Comments

1 2 3 Next › Last »

Rogach commented on 2020-10-30 20:49

@tallero - glade-sharp was never provided by gnome-sharp package, these bindings were included in gtk-sharp-2 package - thus I do not see how I can help here.

tallero commented on 2020-10-30 20:41

actually is banshee (<-mono-upnp` <- gnome-sharp) depends on it.

Rogach commented on 2020-10-24 08:16

@tallero Seems that gtk-sharp-2 removed libglade and thus glade-sharp bindings are not being provided anymore.

gnome-sharp depends on Glade only in EditorShell helper from Gconf.PropertyEditor, which seems to be unused - I added a patch that removes it from the build and package now builds without errors.

tallero commented on 2020-10-23 02:38

glade-sharp is missing.

quequotion commented on 2020-03-30 09:52

I no longer have a use for this package, so I'll leave it for someone else to maintain.

FabioLolix commented on 2020-03-16 22:49

For who need gconf-sharp only I have a dedicated pkgbuild: https://github.com/FabioLolix/PKGBUILD-AUR_fix/blob/master/g/gconf-sharp/PKGBUILD

quequotion commented on 2019-11-10 09:19

This metapackage has a significant AUR dependency chain. In order to build it in a clean chroot (without using an AUR helper), you will have to preinstall its dependencies and their dependencies (after clean chroot building each of them):

makechrootpkg -c -r $CHROOT \
-I ../libgnomeui/libgnomeui-2.24.5-3-x86_64.pkg.tar.xz \
-I ../libbonoboui/libbonoboui-2.24.5-3-x86_64.pkg.tar.xz \
-I ../libgnome/libgnome-2.32.1-7-x86_64.pkg.tar.xz \
-I ../libgnomecanvas/libgnomecanvas-2.30.3-4-x86_64.pkg.tar.xz \
-I ../libgnome/libgnome-data-2.32.1-7-x86_64.pkg.tar.xz \
-I ../gnome-vfs/gnome-vfs-2.24.4-11-x86_64.pkg.tar.xz \
-I ../gnome-mime-data/gnome-mime-data-2.18.0-8-any.pkg.tar.xz \
-I ../gamin/gamin-0.1.10-9-x86_64.pkg.tar.xz \
-I ../libbonobo/libbonobo-2.32.1-4-x86_64.pkg.tar.xz \
-I ../orbit2/orbit2-2.14.19-7-x86_64.pkg.tar.xz

FabioLolix commented on 2019-09-15 14:39

gconf-sharp is available in AUR now

quequotion commented on 2019-07-14 00:06

@FabioLolix

If the source is still out there I'll try to ressurect it as a new AUR package (don't remember which it was actually in), to be honest though gnome-sharp is long dead :( currently I only need it for glippy, which is also long dead :(

One of these days we'll have to move on.

FabioLolix commented on 2019-07-13 16:16

gconf-sharp dependency is no more present in the repo or AUR