Package Details: gazebo 10.1.0-2

Git Clone URL: (read-only)
Package Base: gazebo
Description: A multi-robot simulator for outdoor environments
Upstream URL:
Licenses: Apache
Submitter: None
Maintainer: billypilgrim
Last Packager: billypilgrim
Votes: 26
Popularity: 0.353831
First Submitted: 2008-10-18 22:59
Last Updated: 2019-07-03 12:43

Dependencies (32)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

acxz commented on 2019-08-08 16:45

@billypilgrim The source installation page for Gazebo ( states that the following dependencies have to be a specific version:

sdformat=6 ignition-common=1 ignition-fuel-tools=1 ignition-math=4 ignition-transport=4 ignition-msgs=1 ignition-cmake=0

As of right now, only ignition-math/transport and sdformat are specified. If the others can be specified that would prevent users from downloading unnecessary higher versioned ignition packages.

acxz commented on 2019-07-08 18:41

The thing with packages like libtar, libccd, etc. is that there is no package in the official repos or the AUR that offers any version below the specified version. Therefore there is no need to specify versioned dependencies for those packages, it is redundant. Any package of libtar you can get will be versioned >= 1.2.

billypilgrim commented on 2019-07-08 14:50

@acxz is right that you do need specific versions of these dependencies. There's an upstream issue with their build system:

I assume that whoever put in the specific versions of libtar and curl that are needed did so because Gazebo won't work with older versions.

acxz commented on 2019-07-06 00:41

@Morganamilo I am 100% sure (you can go ahead and try building it yourself if you do not believe me).

I do agree with you on the second point tho. The version dependencies of libtar>=1.2 and curl>=4 are completely unnecessary and should be removed.

Morganamilo commented on 2019-07-05 17:13

@acxz are you totally sure?

If this package truly requires sdformat=6 and say, not 5 or 7, then that's fair enough.

But arch's general policy is to not over use versioned depends. There's no need to specify stuff like libtar>=1.2 and curl>=4. And your total over use of versioned depends leads me to assume sdformat=6 is also unneeded.

acxz commented on 2019-07-05 16:57

@Morganamilo Versioned depends are needed for this package, since the package does not build with other versions of that dependency. Would there be a better way?

Morganamilo commented on 2019-07-04 18:32

Please avoid using versioned depends.

Anonymous comment on 2019-07-01 16:36

I had two issues spawning models via roslaunch in gazebo. The fisrt was;

Traceback (most recent call last):
  File "/opt/ros/melodic/lib/gazebo_ros/spawn_model", line 25, in <module>
    from urlparse import urlsplit, SplitResult
ModuleNotFoundError: No module named 'urlparse'

I fixed it with:

sudo sed -i.bak 's/urlparse/urllib.parse/' /opt/ros/melodic/lib/gazebo_ros/spawn_model

The second appeared after I fixed the first one and was:

  File "/opt/ros/melodic/lib/python3.7/site-packages/gazebo_msgs/srv/", line 103, in serialize
    _x = _x.encode('utf-8')
AttributeError: 'bytes' object has no attribute 'encode'

I fixed it with:

sudo sed -i.bak 's/python3 or type(_x) == unicode/type(_x) == str/' /opt/ros/melodic/lib/python3.7/site-packages/gazebo_msgs/srv/

acxz commented on 2019-06-29 14:36

@billypilgrim I am also getting the same error as @astier. Can this package be fixed so that it works?

It seems as tho the fix is simply specifying the version numbers for dependent packages, i.e. ignition-transport=4 instead of ignition-transport>=4

Anonymous comment on 2019-06-29 10:15

-- BUILD ERRORS: These must be resolved before compiling.
--      Missing: SDF version >=6. Required for reading and writing SDF files.
--      Missing: Ignition msgs1 library (libignition-msgs-dev).
--      Missing: Ignition math (libignition-math4-dev)
--      Missing: Ignition Transport (libignition-transport4-dev)

ignition-transport, ignition-math, etc. are installed however.