Package Details: gapi-ocaml 0.3.19-1

Git Clone URL: https://aur.archlinux.org/gapi-ocaml.git (read-only, click to copy)
Package Base: gapi-ocaml
Description: A simple OCaml client for Google Services.
Upstream URL: https://astrada.github.io/gapi-ocaml/
Keywords: api gapi google ocaml
Licenses: MIT
Submitter: WhyNotHugo
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 44
Popularity: 0.000075
First Submitted: 2013-07-08 03:56
Last Updated: 2020-05-10 17:33

Pinned Comments

nerflad commented on 2019-09-10 10:13

@caseyjp1 It's not a problem with the build. Read the error message. You have updated ocaml since the last time you compiled this package so you need to recompile all the dependencies. Use "pacman -Qo [.cmi filename]" to find which packages to rebuild. Or if you're brave, pacman -Rsc gapi-ocaml && pacman -Sc and start from scratch.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

ginoboy commented on 2018-02-04 13:36

File "src/gapi/gapiDate.mli", line 1: Error: /usr/lib/ocaml/netstring/netdate.cmi is not a compiled interface for this version of OCaml. It seems to be for an older version of OCaml.

snakeroot commented on 2017-12-21 15:59

@nerflad: 0.3.6-2 works for me (i.e., builds, installs and allows mounting of my Google drive).

Thanks for the quick fix.

nerflad commented on 2017-12-21 02:13

@ginoboy: The build should be working now, skipping the installation of the LICENSE and README.md files fixed it. Thanks for the tip @snakeroot.

ginoboy commented on 2017-12-19 16:59

Creating directory /usr/doc/gapi-ocaml [ERROR] Failure during install

opam-version 1.2.2
os linux

/usr/bin/opam-installer: "mkdir" failed on /usr/doc: Permission denied

snakeroot commented on 2017-12-19 16:30

@RemoteAdmin

After a failed build, in 0.3.6 source directory in your build directory, edit the following file:

[build]/src/gapi-ocaml-0.3.6/_build/default/gapi-ocaml.install

and delete the lines beginning with "doc:[" all the way to the bottom of the file.

then makepkg -e

RemoteAdmin commented on 2017-12-19 14:49

Build currently fails with:

/usr/sbin/opam-installer: "mkdir" failed on /usr/doc: Permission denied ==> ERROR: A failure occurred in package(). Aborting...

It seems like opam-installer tries to create a folder outside of the build context. Is there a opam-installer parameter missing to limit installation to package folder instead of system root?

nerflad commented on 2017-12-05 23:05

@RX14: Please try rebuilding/reinstalling ocamlnet from the AUR and see if the build still fails.

RX14 commented on 2017-12-04 10:35

I get this error while compiling: https://gist.github.com/RX14/25688d115639028fe5ac55953f401193

alexislc commented on 2017-10-20 21:29

@nerflad thanks that solved the issue ...

nerflad commented on 2017-10-20 16:53

@alexislc: Please try rebuilding/reinstalling ocamlnet from the AUR and see if the build still fails.