Package Details: gapi-ocaml 0.3.19-1

Git Clone URL: https://aur.archlinux.org/gapi-ocaml.git (read-only, click to copy)
Package Base: gapi-ocaml
Description: A simple OCaml client for Google Services.
Upstream URL: https://astrada.github.io/gapi-ocaml/
Keywords: api gapi google ocaml
Licenses: MIT
Submitter: WhyNotHugo
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 44
Popularity: 0.000075
First Submitted: 2013-07-08 03:56
Last Updated: 2020-05-10 17:33

Pinned Comments

nerflad commented on 2019-09-10 10:13

@caseyjp1 It's not a problem with the build. Read the error message. You have updated ocaml since the last time you compiled this package so you need to recompile all the dependencies. Use "pacman -Qo [.cmi filename]" to find which packages to rebuild. Or if you're brave, pacman -Rsc gapi-ocaml && pacman -Sc and start from scratch.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

MaxG13 commented on 2019-09-07 13:21

I could not install the package, I got this log:

==> Starting build()...
File "/usr/lib/ocaml/yojson/dune-package", line 3, characters 1-8:
3 | (version c608c6d)
     ^^^^^^^
Error: Unknown field version
==> ERROR: A failure occurred in build().
    Aborting...

Removing the mentioned line from /usr/lib/ocaml/yojson/dune-package resolved the issue.

nerflad commented on 2019-09-06 01:39

@PPlatypus: Well, that's troubling. I maintained that package for a long time in the AUR until it was deleted and added to [community] about 18 months ago. Now it appears it has been removed without an announcement.

I've created a forum thread about this and will update as soon as I have more info: https://bbs.archlinux.org/viewtopic.php?pid=1862055#p1862055

PPlatypus commented on 2019-09-06 01:07

Can no longer build - ocaml-yojson is unavailable.

nerflad commented on 2018-12-17 00:37

@Kunda: It's okay! Just rebuild them from the AUR. It's not the packages that have changed, but the ocaml libraries in the Arch distribution (and therefore on your own system). Currently your ocamlnet and ocaml-extlib are compiled against the older versions. Hope this helps.

Kunda commented on 2018-12-17 00:29

The build is not broken. Looks like ocamlnet and extlib need to be recompiled on your system.

@nerflab sorry for being a newb but how do I tell pacman to rebuild said packages?

gudwin commented on 2018-12-07 14:07

I always get trouble with these ... for some reason, when ocaml is upgraded, ocaml-curl, ocaml-xmlm ocaml-yojson and many other derived packages are not recompiled, and this error appears for all of them. The process of fixing all these errors is tedious and must be made manually. There might be a way of forcing them to being recompiled ?

nerflad commented on 2018-12-06 00:12

@Kunda: The build is not broken. Looks like ocamlnet and extlib need to be recompiled on your system.

Kunda commented on 2018-12-05 17:04

Build breaks

==> Validating source files with sha256sums...
    v0.3.9.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting v0.3.9.tar.gz with bsdtar
==> Starting build()...
      ocamlc src/gapi/.gapi_ocaml.objs/gapiCore.{cmo,cmt} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -intf-suffix .ml -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiCore.cmo -c -impl src/gapi/gapiCore.ml)
File "src/gapi/gapiCore.ml", line 1:
Error: /usr/lib/ocaml/extlib/extString.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiDate.{cmi,cmti} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiDate.cmi -c -intf src/gapi/gapiDate.mli)
File "src/gapi/gapiDate.mli", line 1:
Error: /usr/lib/ocaml/netstring/netdate.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiPipe.{cmi,cmti} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiPipe.cmi -c -intf src/gapi/gapiPipe.mli)
File "src/gapi/gapiPipe.mli", line 1:
Error: /usr/lib/ocaml/netstring/netchannels.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiAuthResponse.{cmo,cmt} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -intf-suffix .ml -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiAuthResponse.cmo -c -impl src/gapi/gapiAuthResponse.ml)
File "src/gapi/gapiAuthResponse.ml", line 1:
Error: /usr/lib/ocaml/extlib/option.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiUtils.{cmi,cmti} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiUtils.cmi -c -intf src/gapi/gapiUtils.mli)
File "src/gapi/gapiUtils.mli", line 1:
Error: /usr/lib/ocaml/netstring/netchannels.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiCurl.{cmi,cmti} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiCurl.cmi -c -intf src/gapi/gapiCurl.mli)
File "src/gapi/gapiCurl.mli", line 1:
Error: /usr/lib/ocaml/curl/curl.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
    ocamlopt src/gapi/.gapi_ocaml.objs/gapiCore.{cmx,o} (exit 2)
(cd _build/default && /usr/bin/ocamlopt.opt -w -40 -w -3-23-27-32-33 -g -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -intf-suffix .ml -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiCore.cmx -c -impl src/gapi/gapiCore.ml)
File "src/gapi/gapiCore.ml", line 1:
Error: /usr/lib/ocaml/extlib/extString.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiConfig.{cmi,cmti} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiConfig.cmi -c -intf src/gapi/gapiConfig.mli)
File "src/gapi/gapiConfig.mli", line 1:
Error: /usr/lib/ocaml/curl/curl.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
      ocamlc src/gapi/.gapi_ocaml.objs/gapiMediaResource.{cmi,cmti} (exit 2)
(cd _build/default && /usr/bin/ocamlc.opt -w -40 -w -3-23-27-32-33 -g -bin-annot -I src/gapi/.gapi_ocaml.objs -I src/gapi/.gapi_ocaml.objs/.private -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -no-alias-deps -o src/gapi/.gapi_ocaml.objs/gapiMediaResource.cmi -c -intf src/gapi/gapiMediaResource.mli)
File "src/gapi/gapiMediaResource.mli", line 1:
Error: /usr/lib/ocaml/netstring/netchannels.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
==> ERROR: A failure occurred in build().
    Aborting...

vyachkonovalov commented on 2018-09-23 17:10

jbuilder install from package() stuck at 'Done: 0/0 (jobs: 1)'
Solved by removing ~/.opam/

nerflad commented on 2018-02-04 19:13

@ginoboy: Recompile ocamlnet and that error will go away. Anytime you see that error, run pacman -Qo /usr/lib/ocaml/netstring/netdate.cmi (or whatever the filename is) to see which package needs to be rebuilt.