Package Details: gapi-ocaml 0.3.16-1

Git Clone URL: https://aur.archlinux.org/gapi-ocaml.git (read-only, click to copy)
Package Base: gapi-ocaml
Description: A simple OCaml client for Google Services.
Upstream URL: https://astrada.github.io/gapi-ocaml/
Keywords: api gapi google ocaml
Licenses: MIT
Submitter: WhyNotHugo
Maintainer: pricechrispy
Last Packager: nerflad
Votes: 46
Popularity: 0.77
First Submitted: 2013-07-08 03:56
Last Updated: 2019-10-07 20:26

Pinned Comments

nerflad commented on 2019-09-10 10:13

@caseyjp1 It's not a problem with the build. Read the error message. You have updated ocaml since the last time you compiled this package so you need to recompile all the dependencies. Use "pacman -Qo [.cmi filename]" to find which packages to rebuild. Or if you're brave, pacman -Rsc gapi-ocaml && pacman -Sc and start from scratch.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

nerflad commented on 2019-12-10 03:31

@Mr.E: please see previous (pinned) comment related to this error.

Mr.E commented on 2019-12-04 17:15

Throws this errors even after reinstalling ocaml

    ==> Starting build()...
    File "src/gapi/gapiDate.mli", line 1:
    Error: /usr/lib/ocaml/netstring/netdate.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiCore.ml", line 1:
    Error: /usr/lib/ocaml/extlib/extString.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiPipe.mli", line 1:
    Error: /usr/lib/ocaml/netstring/netchannels.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiAuthResponse.ml", line 1:
    Error: /usr/lib/ocaml/extlib/option.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiUtils.mli", line 1:
    Error: /usr/lib/ocaml/netstring/netchannels.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiCurl.mli", line 1:
    Error: /usr/lib/ocaml/curl/curl.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiConfig.mli", line 1:
    Error: /usr/lib/ocaml/curl/curl.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    File "src/gapi/gapiMediaResource.mli", line 1:
    Error: /usr/lib/ocaml/netstring/netchannels.cmi
           is not a compiled interface for this version of OCaml.
    It seems to be for an older version of OCaml.
    ==> ERROR: A failure occurred in build().
        Aborting...
    Error making: gapi-ocaml

nerflad commented on 2019-10-04 21:08

@kureta: please read previous comments related to this error.

kureta commented on 2019-09-30 12:48

Build fails with the following

==> Starting build()...
File "src/gapi/gapiDate.ml", line 1:
Error: The files /usr/lib/ocaml/netstring/netdate.cmi
       and /usr/lib/ocaml/unix.cmi make inconsistent assumptions
       over interface Stdlib__bigarray
File "src/gapi/gapiUtils.mli", line 1:
Error: The files /usr/lib/ocaml/stdlib__bigarray.cmi
       and /usr/lib/ocaml/netstring/netchannels.cmi
       make inconsistent assumptions over interface Stdlib__bigarray
File "src/gapi/gapiCurl.mli", line 1:
Error: The files /usr/lib/ocaml/curl/curl.cmi
       and src/gapi/.gapi_ocaml.objs/byte/gapiCore.cmi
       make inconsistent assumptions over interface Stdlib__bigarray
File "src/gapi/gapiConfig.mli", line 1:
Error: The files /usr/lib/ocaml/curl/curl.cmi
       and src/gapi/.gapi_ocaml.objs/byte/gapiCore.cmi
       make inconsistent assumptions over interface Stdlib__bigarray
File "src/gapi/gapiMediaResource.mli", line 1:
Error: The files /usr/lib/ocaml/stdlib__bigarray.cmi
       and /usr/lib/ocaml/netstring/netchannels.cmi
       make inconsistent assumptions over interface Stdlib__bigarray
File "src/gapi/gapiJson.mli", line 1:
Error: The files src/gapi/.gapi_ocaml.objs/byte/gapiCore.cmi
       and src/gapi/.gapi_ocaml.objs/byte/gapiDate.cmi
       make inconsistent assumptions over interface Stdlib__bigarray
==> ERROR: A failure occurred in build().
    Aborting...
Error making: gapi-ocaml

nerflad commented on 2019-09-18 00:39

Updated to 0.3.15. google-drive-ocamlfuse should be working again. Report any issues.

nerflad commented on 2019-09-10 10:13

@caseyjp1 It's not a problem with the build. Read the error message. You have updated ocaml since the last time you compiled this package so you need to recompile all the dependencies. Use "pacman -Qo [.cmi filename]" to find which packages to rebuild. Or if you're brave, pacman -Rsc gapi-ocaml && pacman -Sc and start from scratch.

caseyjp1 commented on 2019-09-10 10:05

Fails to build.

Multiple errors with the latest version of this: Error: various .cmi files and then for each error:

"is not a compiled interface for this version of OCaml. It seems to be for an older version of OCaml."

nerflad commented on 2019-09-10 05:25

Now that things are nominal, I've bumped the version to 0.3.13. Please report any issues.

nerflad commented on 2019-09-10 05:17

@PPlatypus: I recreated AUR packages for the dependencies that were recently removed from [community]. Thanks for the tip.

nerflad commented on 2019-09-10 05:14

@MaxG13 thanks for the tip. I fixed the ocaml-yosjon package. Should be working now.