Package Details: gandi.cli 1.5-1

Git Clone URL: https://aur.archlinux.org/gandi.cli.git (read-only)
Package Base: gandi.cli
Description: Gandi command line interface
Upstream URL: http://cli.gandi.net
Licenses: GPL3
Submitter: rdoursenaud
Maintainer: rdoursenaud
Last Packager: rdoursenaud
Votes: 5
Popularity: 0.012329
First Submitted: 2014-09-20 12:27
Last Updated: 2019-06-05 09:56

Latest Comments

« First ‹ Previous 1 2

rdoursenaud commented on 2015-11-06 07:52

@FMB The bug is fixed upstream at https://github.com/Gandi/gandi.cli/commit/bb39130b9b2adf48578b5625864d2a0ae3d0b876
Let's wait for a new release.
In the meantime, you can edit the PKGBUILD and comment the test, knowing that the contact command won't work…

FMB commented on 2015-11-05 10:49

Now I can install python-click, but gandi.cli won't install because tests fail. Some of these errors look like incompatibilities between Python 2 and Python 3.

FMB commented on 2015-11-04 15:35

Some kind of cache, I guess. I'll report the issue if it still can't be installed by tomorrow.

rdoursenaud commented on 2015-11-04 15:12

@FMB python-click is supposed to be in community and has been updated today: https://www.archlinux.org/packages/community/any/python-click/
But I can't seem to be able to (re-)install it either.
You may want to report a bug to Arch Linux itself.

FMB commented on 2015-11-04 14:02

It looks like python-click is no longer available on the AUR... Now we've got python-click-{log,plugins,repl-git,threading} and I've got no idea which ones to declare as dependencies.

rdoursenaud commented on 2015-03-07 18:40

@Sheerys Thanks for the report. I didn't see the new dependency.
Package updated.

Spheerys commented on 2015-03-05 19:05

When I launch the package, I have this erreor :

Traceback (most recent call last):
File "/usr/bin/gandi", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3020, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 614, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 920, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 807, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: IPy

rdoursenaud commented on 2014-11-01 09:24

Thanks for reporting @imrehg. I checked with the authors that this dependency is not needed and will be removed in future releases. Updated the package too soon. Reverted back to depend on click 3.1.

imrehg commented on 2014-11-01 06:05

This tool requires python-click<=3.1, at the moment provided by aur/python-click-3.1 After install it does not run unless the PKGBUILD is updated to require python-click-3.1 instead of the default python-click.