Package Details: gamescope 3.8.3-0

Git Clone URL: https://aur.archlinux.org/gamescope.git (read-only, click to copy)
Package Base: gamescope
Description: The micro-compositor formerly known as steamcompmgr
Upstream URL: https://github.com/Plagman/gamescope
Keywords: gamescope session steamcompmgr steamos
Licenses: BSD, custom:BSD 2-Clause "Simplified" License
Conflicts: gamescope-git, libliftoff
Provides: libliftoff=0.0.0, steamcompmgr
Replaces: steamcompmgr
Submitter: PedroHLC
Maintainer: scrufulufugus
Last Packager: scrufulufugus
Votes: 3
Popularity: 0.038632
First Submitted: 2020-04-09 22:16
Last Updated: 2021-06-09 23:33

Dependencies (23)

Required by (2)

Sources (3)

Latest Comments

scrufulufugus commented on 2021-01-10 00:37

@Toadfield Mangohud works fine, you just need to call it inside of Gamescope.

gamescope -w $width -h $height -- mangohud $command

Toadfield commented on 2021-01-10 00:32

It is very buggy,if I try to use it with other programs like Mangohud,then it doesn't work.

cobaltspace commented on 2020-11-10 18:44

You don't need to use git to get the subprojects. These can be used as the sources instead:

https://github.com/emersion/libliftoff/archive/95da3ee649fe42bb147789d5092e95c8f61fab77.tar.gz
https://github.com/swaywm/wlroots/archive/751a21d94f1b4f0345d040ddfd54b723631d5991.tar.gz

Using this, git isn't a make dependency anymore. They can also then be checksumed (where sha256sum is preferred to md5sum)

Toadfield commented on 2020-09-14 00:01

If I try to build it,I get this:

|subprojects/wlroots/meson.build:196: WARNING: Passed invalid keyword argument "version". |WARNING: This will become a hard error in the future. FAILED: subprojects/wlroots/libwlroots.so.3.6.1 collect2: error: ld returned 1 exit status

Does anyone know what I have to do?

PedroHLC commented on 2020-05-08 16:24

Bumped to 3.6.1, removed wlroots files as it's statically linked.

ReNoM commented on 2020-05-08 15:55

I'm trying to start gamescope, but get segfault with the following errors:

glamor: No eglstream capable devices found
The XKEYBOARD keymap compiler (xkbcomp) reports:
Internal error: Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server
2020-05-08 18:52:25 - [types/wlr_surface.c:609] New wlr_surface ????? (res ?????)
2020-05-08 18:52:25 - [xwayland/xwayland.c:349] sent SIGUSR1 to process ?????
2020-05-08 18:52:25 - [xwayland/xwayland.c:227] Xserver is ready
The XKEYBOARD keymap compiler (xkbcomp) reports:
Warning: Unsupported maximum keycode 569, clipping.
X11 cannot support keycodes above 255.
Internal error: Could not resolve keysym Invalid
Errors from xkbcomp are not fatal to the X server
(EE) failed to read Wayland events: Broken pipe
Segmentation fault (core dumped)

Any ideas?

PedroHLC commented on 2020-04-09 22:17

If you're using sway or wayfire you may not want to use this package, as it uses Plagman's wlroots fork!