Package Details: gala-git 3.2.0.r73.c49189b-1

Git Clone URL: https://aur.archlinux.org/gala-git.git (read-only, click to copy)
Package Base: gala-git
Description: The Pantheon Window Manager
Upstream URL: https://github.com/elementary/gala
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: gala
Provides: gala, libgala.so
Submitter: alucryd
Maintainer: quequotion
Last Packager: quequotion
Votes: 57
Popularity: 0.137088
First Submitted: 2017-05-19 12:52
Last Updated: 2020-03-15 17:37

Dependencies (31)

Required by (8)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Erde commented on 2019-11-06 18:59

pkgbuild -si does not resolve the dependency unless your additional repo is activated. This might be a more proper link as it contains said repo information: https://wiki.archlinux.org/index.php/Pantheon

(not that it even seems possibly to assemble a working Pantheon desktop as things are now regardless)

alucryd commented on 2019-11-06 13:32

https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages

Prosto_user commented on 2019-11-06 06:49

Package cannot be assembled...

Run-time dependency libmutter found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-0 found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-1 found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-2 found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-3 found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-4 found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-5 found: NO (tried pkgconfig and cmake)
Run-time dependency libmutter-6 found: NO (tried pkgconfig and cmake)

meson.build:314:1: ERROR: Problem encountered: No supported mutter library found!

A full log can be found at /home/Tom/.cache/yay/gala-git/src/build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
Error making: gala-git

alucryd commented on 2019-11-04 10:37

switched back to master branch

lamelos commented on 2019-11-01 09:47

mutter3.3 support has been merged in master (see https://github.com/elementary/gala/pull/566) so the git source should be updated to:

git+https://github.com/elementary/gala.git

A.J commented on 2019-10-27 18:23

no matter what i did it fails to build with ltrans.o error , any help ?

it's actually the same error as @Nietzsche

GizmoTheGreen commented on 2019-09-27 18:32

hello @alucryd it's not on Arch Arm [extra]. so an AUR package would be helpful if you can.

alucryd commented on 2019-08-26 17:15

Why would I do that? It's in [extra] already.

PedroHLC commented on 2019-08-21 12:12

Hi @alucryd, could you push libmutter to AUR?

alucryd commented on 2019-08-17 15:14

It builds fine in a chroot with our repo libmutter now.