Package Details: gajim-plugin-omemo 2.6.80-1

Git Clone URL: https://aur.archlinux.org/gajim-plugin-omemo.git (read-only, click to copy)
Package Base: gajim-plugin-omemo
Description: Gajim plugin for OMEMO Multi-End Message and Object Encryption.
Upstream URL: https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin
Licenses: GPL
Conflicts: gajim-plugin-omemo-git
Provides: gajim-plugin-omemo
Submitter: cippaciong
Maintainer: cippaciong
Last Packager: cippaciong
Votes: 47
Popularity: 1.61
First Submitted: 2016-01-08 01:17
Last Updated: 2020-07-22 19:38

Pinned Comments

cippaciong commented on 2020-07-02 21:01

Read this before flagging the package as out-of-date

Hello everyone, please be aware that the versioning system used by the omemo plugin can be a little misleading and it might appear that this package is out-of-date while it is not. The versioning convention of the plugin uses different releases for different gajim versions. As an example, at the time of writing the latest version of the plugin compatible with gajim master branch is 2.7.7 but the latest version compatible with gajim 1.1, the one currently present in the repositories, is 2.6.30.

Before flagging this package as out-of-date, please make sure that you are looking at the right changelog for the current stable release shipped in the official arch repositories. In other words, make sure that you are looking at the changelog on the right branch on gajim's gitlab.

For gajim 1.1 the correct changelog is this one: https://dev.gajim.org/gajim/gajim-plugins/-/blob/gajim_1.1/omemo/CHANGELOG

Thanks :)

Latest Comments

1 2 3 4 5 6 Next › Last »

cippaciong commented on 2020-07-21 20:27

Hello everyone, I'm updating this package to version 2.6.79 since the latest version (2.6.80) is not available in the upstream ftp repository at the moment. I have already reported the issue upstream and I will update this package as soon as they are able to fix it.

TrialnError commented on 2020-07-19 20:17

~~But the latest version of gajim in the Arch repos is 1.2.x. And looking at the changelog on the upstream 1.2 branch, the latest omemo version should be 2.6.80?~~

Edit: Bad wording from my side. I thought Arch already packaged 1.2.0. But 1.2 just dropped into the repos this day. Nevertheless this is now properly out of date :)

cippaciong commented on 2020-07-02 21:01

Read this before flagging the package as out-of-date

Hello everyone, please be aware that the versioning system used by the omemo plugin can be a little misleading and it might appear that this package is out-of-date while it is not. The versioning convention of the plugin uses different releases for different gajim versions. As an example, at the time of writing the latest version of the plugin compatible with gajim master branch is 2.7.7 but the latest version compatible with gajim 1.1, the one currently present in the repositories, is 2.6.30.

Before flagging this package as out-of-date, please make sure that you are looking at the right changelog for the current stable release shipped in the official arch repositories. In other words, make sure that you are looking at the changelog on the right branch on gajim's gitlab.

For gajim 1.1 the correct changelog is this one: https://dev.gajim.org/gajim/gajim-plugins/-/blob/gajim_1.1/omemo/CHANGELOG

Thanks :)

doskoi commented on 2018-11-16 03:58

There is no version of this plugin for Gajim 1.1.0?

cippaciong commented on 2018-10-12 09:24

@LukeLR: sorry, I don't know how I didn't notice your comment sooner. python-axolotl-curve25519 is a dependency of python-axolotl which in turn is a dependency of this plugin so it shouldn't be added explicitly.

user20159 commented on 2018-09-09 19:57

What about python-axolotl-curve25519? Shouldn't it also be a dependency? Since Gajim couldn't enable the plugin when I had only the -git version installed from AUR...

cippaciong commented on 2018-08-06 21:37

@thededem: thanks for reporting, I will update the PKGBUILD.

thededem commented on 2018-08-06 19:03

After updating gajim I had the problem, that the omemo plugin was not recognized. As it turned out, the directories in package() in the PKGBUILD need to be updated to python3.7.

ani commented on 2018-04-09 07:26

makepkg -sri ==> Making package: gajim-plugin-omemo 2.5.8-1 (Mon Apr 9 09:25:28 CEST 2018) ==> Checking runtime dependencies... ==> Installing missing dependencies... [sudo] password for andreas: resolving dependencies... looking for conflicting packages... :: gajim and gajim-git are in conflict. Remove gajim-git? [y/N] error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: gajim and gajim-git are in conflict ==> ERROR: 'pacman' failed to install missing dependencies.

cippaciong commented on 2018-04-08 23:16

This is a bug and has been solved in the latest version, released a couple of hours ago, I will update the package tomorrow. Cheers