Package Details: gabedit 2.5.0-1

Git Clone URL: https://aur.archlinux.org/gabedit.git (read-only, click to copy)
Package Base: gabedit
Description: A graphical user interface to computational chemistry packages
Upstream URL: http://gabedit.sourceforge.net/
Licenses: custom
Submitter: None
Maintainer: Sylogista
Last Packager: Sylogista
Votes: 3
Popularity: 0.000000
First Submitted: 2016-04-12 18:12
Last Updated: 2018-12-16 01:24

Latest Comments

1 2 Next › Last »

iamkaant commented on 2021-02-20 14:59

@gpettinello thank you, I was able to install gabedit using your PKGBUILD, but I needed to install pangox-compat explicitly. I had pango installed, but without pangox-compat during building gabedit I've got an error

/usr/sbin/ld: cannot find -lpangox-1.0

collect2: error: ld returned 1 exit status

gpettinello commented on 2021-01-03 12:37

@Sylogista yes I have pango installed and that gives me no errors. So the dependency should be pango and not for instance pangox-compat (AUR) Sorry for the mistake

Sylogista commented on 2021-01-02 18:36

@gpettinello: I've tried your PKGBUILD on fresh Arch and it gives errors. Could you check it on fresh Arch too? For me it looks like you have pangox... could you also check ldconfig -p | grep pangox?

gpettinello commented on 2021-01-02 17:49

I was able to compile without pangox and without errors. Here is the PKGBUILD

# Maintainer: Hilary Jendrasiak <sylogista@sylogista.pl>
# Contributor: ross <prwarren8 at gmail dot com>
# Contributor: gianluca <g_pet@hotmail.com>

pkgname=gabedit
pkgver=2.5.1
pkgrel=1
pkgdesc='A graphical user interface to computational chemistry packages'
arch=('i686' 'x86_64')
url='http://gabedit.sourceforge.net/'
license=('Custom')
depends=('gtkglext' 'gtk2')
_pkgver="${pkgver//\./}_280820"
source=("https://sites.google.com/site/allouchear/Home/gabedit/download/GabeditSrc$_pkgver.tar.gz" 
        'gabedit.desktop')

sha512sums=('f05187f25fe65e5ed48c339be4b49fe1e1e71f48c02d1d5a95a8d025f5d3a85fffc3f8bc66c5f0306935a2077cd73997b02e15472c753cb3eabb9ce06ff6391c' 
            'd9d2a7c6aab76ce3ba0ae11a8fd22ae7d3538dbc07221ff81fabf74fbcb57e51c788e31b1e255e99aab0618ed846a2cf3eea7083362151fb798be4fafdac0d4e')

build()
{
    cd "$srcdir/GabeditSrc$_pkgver/"
    cp platforms/CONFIG.unix CONFIG
    sed -i 's/-Wno-unused-variable/-Wno-unused-variable -fcommon/g' CONFIG
    make
    #LDFLAGS+=/lib/libm.so.6 make
}
package()
{
    mkdir -p "$pkgdir/usr/bin"
    mkdir -p "$pkgdir/usr/share/licenses/gabedit"
    mkdir -p "$pkgdir/usr/share/applications/"

    install -D -m655 "$srcdir/GabeditSrc$_pkgver/gabedit" \
    "$pkgdir/usr/bin/"
    install -D -m644 "$srcdir/GabeditSrc$_pkgver/License" \
    "$pkgdir/usr/share/licenses/gabedit"

    # install .desktop file
    install -D -m644 "$srcdir/gabedit.desktop" \
    "$pkgdir/usr/share/applications/"
    install -D -m644 "$srcdir/GabeditSrc$_pkgver/icons/Gabedit48.png" \
    "$pkgdir/usr/share/pixmaps/gabedit.png"
}

You see that I moved to version 2.5.1 and that I had to use -fcommon to avoid the ld errors with gcc 10. I will mark the package as out of date. Please modify the PKGBUILD. Thanks

HaoZeke commented on 2020-09-08 09:19

Requires pangox

Should be added as a dependency. Also fails due to errors noted by a.kudelin.

Full error log: https://hatebin.com/ganrhutzem

a.kudelin commented on 2020-09-05 17:55

Cannot build due to lots of errors like:
/usr/bin/ld: tmp/AxesGeomGL.o:(.bss+0x7d0): multiple definition of `alpha_opacity'; tmp/AnimationMD.o:(.bss+0x3c8): first defined here

iamkaant commented on 2020-04-14 12:28

Hi guys! I get segfault each time I press "Draw geometry" or "Display geometry" buttons. Does anyone have the same issue?

Sylogista commented on 2019-03-06 14:24

Hi avo1990! Thank you for your appreciation and the report. I've that little bug too, no matter on gnome, or not. In my opinion this is not the PKGBUILD problem. Looks more like linking buttons to actions issue. I'm reporting that bug right now. We will know soon.

avo1990 commented on 2019-03-06 02:30

Hi! Thanks so much for the package! I noticed that the close icon for some popup windows do not work (gnome) but the actual close option at the bottom of the window works but not a big deal.

KbanKiller commented on 2017-05-13 17:04

Thanks, it's perfect