Package Details: funkwhale 0.20.1-1

Git Clone URL: https://aur.archlinux.org/funkwhale.git (read-only, click to copy)
Package Base: funkwhale
Description: A self-hosted, modern free and open-source music server, heavily inspired by Grooveshark.
Upstream URL: https://funkwhale.audio/
Licenses: GPL3
Submitter: getzze
Maintainer: getzze
Last Packager: getzze
Votes: 1
Popularity: 0.000506
First Submitted: 2018-11-03 23:41
Last Updated: 2019-11-15 02:16

Dependencies (56)

Required by (0)

Sources (10)

Pinned Comments

getzze commented on 2018-11-05 09:29

Follow the instructions on the wiki [https://wiki.archlinux.org/index.php/Funkwhale] or on the official documentation to finish the installation and configure your instance.

Latest Comments

getzze commented on 2019-08-20 22:27

python-pyld was flagged out-of-date, it should be updated to the correct version soon. Funkwhale is a young project that is using cutting-edge libraries (and a lot of them!), it is difficult to keep pace, even on Arch that is rolling-release. Upstream advises to use Docker installation to avoid dependency problems. Using this package you will have to manually update dependencies sometimes, but with a good AUR helper it is not so complicated, for python dependencies you usually only have to change the pkgver in the PKGBUILD.

JCaesar commented on 2019-08-18 06:03

When trying aur sync funkwhale, this failed with a

invalid node: python-pyld 0.7.1 (required: >=1.0.4)

I ended up patching the pyld build [https://github.com/jcaesar/python-pyld-archlinux] and installing it with repo-add $(aur repo).tar python-pyld-1.0.5-0-any.pkg.tar.xz, but that can hardly be the normal way of doing it?

fryfrog commented on 2019-03-14 05:39

This also depends on python-django-rest-framework which hasn't been updated to the version you require. :(

getzze commented on 2019-02-22 00:00

In v0.18, the default ip address changed to 127.0.0.1, the env file is now stored in /srv/funkwhale/config/env and file permissions changed. Follow the new instructions on the wiki.

Superpiffer commented on 2019-02-05 11:42

The package is outdated. Also on first installation, the user "funkwhale" doesn't exist, so the build failed.

getzze commented on 2018-11-05 09:29

Follow the instructions on the wiki [https://wiki.archlinux.org/index.php/Funkwhale] or on the official documentation to finish the installation and configure your instance.