Package Details: funguloids 1.06.4-12

Git Clone URL: https://aur.archlinux.org/funguloids.git (read-only, click to copy)
Package Base: funguloids
Description: 3D game about collecting mushrooms in outerspace
Upstream URL: http://funguloids.sourceforge.net/
Licenses: zlib
Submitter: None
Maintainer: IooNag
Last Packager: IooNag
Votes: 12
Popularity: 0.000000
First Submitted: 2007-08-13 01:51
Last Updated: 2018-10-21 10:16

Latest Comments

1 2 Next › Last »

IooNag commented on 2019-10-09 20:25

I confirm it is broken, but I won't have time in the next few weeks to search what OGRE broke this time and to write a patch to make funguloids work again. If you would like to contribute to this package, I maintain it on https://github.com/fishilico/funguloids and can accept Pull Requests there.

Singularity commented on 2019-09-24 01:46

Seems compiling broke once again … :(

IooNag commented on 2018-06-02 16:38

I fixed the package. OGRE 1.11 and OIS 1.4 had breaking updates (cf. https://github.com/fishilico/funguloids/commits/117ce7adc7688cd31d92b24b3717c0fabcb26a87 for details about the fixes)

Singularity commented on 2017-04-30 12:48

It's not compiling with the new ogre anymore

herzmeister commented on 2016-06-25 21:08

working again now, thanks

IooNag commented on 2016-06-16 19:15

Indeed. As the game does not work properly with Lua 5.3, it still needs lua 5.1, provided by lua51 package. Actually a few days ago the package changed the name of the pkg-config file from "lua5.1.pc" to "lua51.pc": https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/lua51&id=d46f4b70dab932996805f93dd386417b86021eb2 . This is what is causing the bug.

Could you please try the following patch? It fixed the bug on my system and I would like to confirm it also fixed it for you before updating the PKGBUILD.

--- a/configure.ac
+++ b/configure.ac
@@ -53,7 +53,9 @@ AC_SUBST(OIS_LIBS)
# LUA ----------------------------------------------------
PKG_CHECK_MODULES(LUA, [lua >= 5.1, lua < 5.2],[],[
PKG_CHECK_MODULES(LUA, [lua5.1 >= 5.1],[],[
- AC_MSG_ERROR(Lua 5.1 not found)
+ PKG_CHECK_MODULES(LUA, [lua51 >= 5.1, lua51 < 5.2],[],[
+ AC_MSG_ERROR(Lua 5.1 not found)
+ ])
])
])

herzmeister commented on 2016-06-16 18:07

Currently doesn't build:

checking wchar.h usability... yes
checking wchar.h presence... yes
checking for wchar.h... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for OGRE... yes
checking for OGRE_OVERLAY... yes
configure: Ogre plugins found in /usr/lib/OGRE
checking for OIS... yes
checking for LUA... no
checking for LUA... no
configure: error: Lua 5.1 not found
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build funguloids.
==> Restart building funguloids ? [y/N]
==> -----------------------------------

I have a later version of Lua installed (Lua 5.3)

IooNag commented on 2014-12-25 11:25

Thanks for reporting this bug. It seems namcap is misleading because it says on my compiled package:
funguloids W: Referenced library 'libboost_system.so.1.56.0' is an uninstalled dependency
funguloids W: Dependency included and not needed ('boost')

... but libboost_system.so is provided by boost-libs, which is required by boost. Whatever, I added boost to the dependencies.

Katsu commented on 2014-12-24 15:13

boost package is missing from Dependencies.

IooNag commented on 2014-08-15 22:20

I adopted and added patches to make funguloids work in an up-to-date Arch system (OGRE 1.9, GCC 4.9.1, etc.)