Package Details: fslint 2.46-1

Git Clone URL: https://aur.archlinux.org/fslint.git (read-only, click to copy)
Package Base: fslint
Description: A utility to find and clean various forms of lint on a filesystem
Upstream URL: http://www.pixelbeat.org/fslint/
Licenses: GPL
Submitter: None
Maintainer: stevenhoneyman
Last Packager: stevenhoneyman
Votes: 299
Popularity: 0.054831
First Submitted: 2007-02-24 01:42
Last Updated: 2017-02-03 13:32

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

dennis123123 commented on 2014-03-28 19:17

How did you get it to run under the older version of python? editing every python script to specify python2.7?

That's the way I tried and got the same failiure

cobalt commented on 2014-03-02 11:28

I had the same "IndexError: list index out of range" with the current 2.44 as I remember, but 2.42 works just fine for me now.

dennis123123 commented on 2014-03-02 10:26

This is the error (again, same with 2.42 or 2.45 beta from the official site:


File "/usr/bin/fslint-gui", line 1582, in on_select_all_but_oldest_in_each_group_activate
self.on_select_all_but_one_in_each_group_activate("oldest")
File "/usr/bin/fslint-gui", line 1616, in on_select_all_but_one_in_each_group_activate
unselect_row = find_row_to_unselect(clist, row, which)
File "/usr/bin/fslint-gui", line 1602, in find_row_to_unselect
while get_selectable(row, row_data) and row < clist.rows:
File "/usr/bin/fslint-gui", line 421, in get_selectable
return row_data[row][0] != '#'
IndexError: list index out of range

dennis123123 commented on 2014-03-02 10:24

Not working for me, but neither is the version from the official site. It must be run under python2.7, but then I get errors when multiselecting, or deleting files or "lint" it finds. Effectively useless, not sure why.

cobalt commented on 2014-02-22 19:22

Not working, downgraded to 2.42

cobalt commented on 2014-02-22 19:18

Not working

rtfreedman commented on 2013-12-26 23:31

PKGBUILD puts docs to /usr/share/fslint/doc/ instead of /usr/share/doc/fslint/

nejsem commented on 2011-01-12 11:48

Hi, the "error" with python instead of python2 is still present in latest release. Isn't it a time to create a archlinux only patch or to edit it in post intall script? ie just add a lines
sed -i "s/\!\/usr\/bin\/env\ python/\!\/usr\/bin\/env\ python2/" /usr/bin/fslint-gui
sed -i "s/\!\/usr\/bin\/env\ python/\!\/usr\/bin\/env\ python2/" /usr/share/fslint/fslint/supprt/rmlint/merge_hardlinks
sed -i "s/\!\/usr\/bin\/env\ python/\!\/usr\/bin\/env\ python2/" /usr/share/fslint/fslint/supprt/rmlint/fixdup
I don't think the author will bother with archlinux-only problem...

Anonymous comment on 2010-11-26 13:13

I couldn't run fslint and used to get this error:
> File "./fslint-gui", line 173
> except getopt.error, msg:
> ^
> SyntaxError: invalid syntax
Simply edit the first line #!/usr/bin/env python to #!/usr/bin/env python2 in these files:
/usr/bin/fslint-gui
/usr/share/fslint/fslint/supprt/rmlint/merge_hardlinks
/usr/share/fslint/fslint/supprt/rmlint/fixdup

This temporary solution is provided by software creator (I've asked him through email) until we get a patch/fix or new release.
Have fun.

jose1711 commented on 2010-10-20 13:59

note that it conflicts with 'rpm' package when it comes to listing available packages on the system