Package Details: frr 7.2.1-2

Git Clone URL: https://aur.archlinux.org/frr.git (read-only, click to copy)
Package Base: frr
Description: FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.
Upstream URL: https://frrouting.org/
Licenses: GPL2
Conflicts: babeld, quagga, quagga_cumulus
Provides: quagga, quagga_cumulus
Submitter: k0ste
Maintainer: k0ste (eugeneai)
Last Packager: k0ste
Votes: 3
Popularity: 0.001661
First Submitted: 2017-02-04 15:24
Last Updated: 2020-01-21 09:09

Latest Comments

1 2 3 Next › Last »

pogojotz commented on 2020-02-10 08:09

@ivoronin https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites AUR users are expected to have base-devel installed and therefore packages included therein are never listed as build-deps

k0ste commented on 2020-02-10 05:19

@ivoronin, this packages already in base-devel.

ivoronin commented on 2020-02-09 15:53

@k0ste you should add autoconf, automake, pkg-config and flex to build-deps

k0ste commented on 2019-07-16 02:50

Added eugeneai patches to this repo.

pogojotz commented on 2019-07-13 21:12

I took the liberty to fork this package into frr-git for people who want to test the upstream HEAD.

k0ste commented on 2019-06-26 03:57

@eugeneai, I was add you to co-maintainers. Now you can push changes to this repo. Your patch is very huge with alot of changes. It is possible to make a PR to frr upstream? frr guys are disposed to changes.

eugeneai commented on 2019-06-23 00:13

I've prepared a package version with improved patches and missing routines included, tested it on my VPN infrastructure of five routers (ospfd and ospfv6d daemons). Works well.

Service is frr.service, that starts frr not frrinit.sh.

https://github.com/eugeneai/frr-arch (a clone of this repo).

Evgeny

eugeneai commented on 2019-05-27 03:35

(about removing endless recursion patch) I've menuioned, that the bug is in the bug list already.https://github.com/FRRouting/frr/issues/852

k0ste commented on 2019-05-10 13:42

@mooteel thanks. Yep, I use outdated version.

napaster commented on 2019-05-10 11:19

Please add this patch. I have 6 instance, but default 5 instance

--- frr 2019-05-10 15:22:28.000000000 +0700
+++ frr.patch   2019-05-10 17:52:37.953763800 +0700
@@ -26,7 +26,7 @@
 # See /usr/share/doc/frr/README.Debian.gz for further information.
 # Keep zebra first and do not list watchfrr!
 DAEMONS="zebra bgpd ripd ripngd ospfd ospf6d isisd babeld pimd ldpd nhrpd eigrpd sharpd pbrd staticd bfdd fabricd"
-MAX_INSTANCES=5
+MAX_INSTANCES=6
 RELOAD_SCRIPT="$D_PATH/frr-reload.py"

 if [ -e /lib/lsb/init-functions ]; then
@@ -508,7 +508,7 @@
 # Read configuration variable file if it is present
 [ -r /etc/default/frr ] && . /etc/default/frr

-MAX_INSTANCES=${MAX_INSTANCES:=5}
+MAX_INSTANCES=${MAX_INSTANCES:=6}

 # Set priority of un-startable daemons to 'no' and substitute 'yes' to '0'
 convert_daemon_prios