Package Details: frescobaldi 3.0.0-3

Git Clone URL: https://aur.archlinux.org/frescobaldi.git (read-only, click to copy)
Package Base: frescobaldi
Description: A LilyPond sheet music text editor.
Upstream URL: http://www.frescobaldi.org/
Keywords: LilyPond
Licenses: GPL
Submitter: None
Maintainer: rdoursenaud
Last Packager: rdoursenaud
Votes: 92
Popularity: 1.34
First Submitted: 2009-01-08 03:10
Last Updated: 2018-12-29 13:41

Dependencies (23)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

hermes14 commented on 2014-03-29 15:19

@zoe
That did the trick, thank you!

zoe commented on 2014-03-29 15:13

@hermes14 :
Just do that :
Remove frescobaldi
Remove python2-poppler-qt
Re-install python2-poppler-qt
Re-install frescobaldi.

@cdemoulins :
La version 2.0.15 est disponible
Installation réussie avec
pkgver=2.0.15
et
mdsum5=31c21a17a2f103199211140123477327

hermes14 commented on 2014-03-29 14:50

I get this error:
[...]
RuntimeError: the sip module implements API v11.0 but the popplerqt4 module requires API v10.1

Full view here: http://pastebin.com/xMpydiP9

Any hint?

hermes14 commented on 2014-03-29 14:48

Traceback (most recent call last):
File "/usr/bin/frescobaldi", line 3, in <module>
import frescobaldi_app.main
File "/usr/lib/python2.7/site-packages/frescobaldi_app/main.py", line 189, in <module>
main()
File "/usr/lib/python2.7/site-packages/frescobaldi_app/main.py", line 160, in main
win = mainwindow.MainWindow()
File "/usr/lib/python2.7/site-packages/frescobaldi_app/mainwindow.py", line 118, in __init__
self.createMenus()
File "/usr/lib/python2.7/site-packages/frescobaldi_app/mainwindow.py", line 880, in createMenus
menu.createMenus(self)
File "/usr/lib/python2.7/site-packages/frescobaldi_app/menu.py", line 62, in createMenus
m.addMenu(menu_file(mainwindow))
File "/usr/lib/python2.7/site-packages/frescobaldi_app/menu.py", line 96, in menu_file
m.addMenu(snippet.menu.TemplateMenu(mainwindow))
File "/usr/lib/python2.7/site-packages/frescobaldi_app/snippet/menu.py", line 140, in __init__
self.addAction(self.tool().actionCollection.templates_manage)
File "/usr/lib/python2.7/site-packages/frescobaldi_app/snippet/menu.py", line 60, in tool
return panelmanager.manager(self.mainwindow()).snippettool
File "/usr/lib/python2.7/site-packages/frescobaldi_app/panelmanager.py", line 34, in manager
return PanelManager.instance(mainwindow)
File "/usr/lib/python2.7/site-packages/frescobaldi_app/plugin.py", line 85, in instance
result.__init__(obj)
File "/usr/lib/python2.7/site-packages/frescobaldi_app/panelmanager.py", line 49, in __init__
self.loadPanel("musicview.MusicViewPanel")
File "/usr/lib/python2.7/site-packages/frescobaldi_app/panelmanager.py", line 79, in loadPanel
__import__(module_name)
File "/usr/lib/python2.7/site-packages/frescobaldi_app/musicview/__init__.py", line 56, in <module>
from . import documents
File "/usr/lib/python2.7/site-packages/frescobaldi_app/musicview/documents.py", line 33, in <module>
import popplerqt4
RuntimeError: the sip module implements API v11.0 but the popplerqt4 module requires API v10.1

contrebasse commented on 2014-03-26 10:50

The optional dependency "python-pygame" should be "python2-pygame".

ryanmcclure commented on 2014-03-07 01:39

Hello! Frescobaldi 2.0.14 was just released today! Can we possibly have the package updated? Thank you!!! :)

donarturo commented on 2013-09-08 21:23

I submit my modified PKGBUILD. I modified only dependencies.
####################3
####################3
pkgname=frescobaldi
pkgver=2.0.10
pkgrel=3
pkgdesc="A LilyPond sheet music editor for KDE4. It aims to be powerful, yet lightweight and easy to use."
arch=('any')
url="http://www.frescobaldi.org/"
license=("GPL")
depends=('lilypond' 'python2-poppler' 'python2-sip' 'python2-pyqt4' 'python2-poppler-qt')
optdepends=('rumor' 'portmidi: MIDI playback' 'python-pygame: MIDI playback')
makedepends=('docbook-xsl')
install=$pkgname.install

source=(http://lilykde.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
md5sums=('e2f1a4d3cca228f4acddb2510464cf78')

package() {
cd $srcdir/$pkgname-$pkgver
python2 setup.py install --root="$pkgdir/" --optimize=1
find $pkgdir -name '*.py' -exec sed -i -e 's/^#!\/usr\/bin\/env python$/#!\/usr\/bin\/env python2/' -e 's/^#!\/usr\/bin\/python$/#!\/usr\/bin\/python2/' {} \;
}
#######################3

cdemoulins commented on 2013-06-18 08:21

Yes, you right but i will just remove this dependency.
It's already a dependency of python2-poppler-qt.

jdarch commented on 2013-06-18 00:31

I beleive the dependency python2-pyqt has changed to python2-pyqt4

ryanmcclure commented on 2013-05-12 20:48

Frescobaldi 2.0.10 just came out. Please update. Thank you!!!