Package Details: freezer-bin 1.1.24-1

Git Clone URL: https://aur.archlinux.org/freezer-bin.git (read-only, click to copy)
Package Base: freezer-bin
Description: Free HQ music streaming app (Official)
Upstream URL: https://git.rip/freezer/freezerpc/
Keywords: music
Licenses: GPL
Conflicts: freezer-appimage, freezer-git
Provides: freezer-bin
Submitter: xandarnull
Maintainer: xandarnull
Last Packager: xandarnull
Votes: 9
Popularity: 1.19
First Submitted: 2021-03-02 16:47
Last Updated: 2021-07-25 19:06

Latest Comments

foozoor commented on 2021-04-30 09:21

I think there is something wrong.
The .desktop Name is freezer, not Freezer.
And the installation folder is /opt/Freezer, not /opt/freezer.

hb20032003 commented on 2021-04-20 17:09

please change the upstream url to https://git.freezer.life/exttex/freezerpc/

xandarnull commented on 2021-04-17 19:54

thanks for the help, done and updated to 1.1.19

eNV25 commented on 2021-04-17 19:01

I've edited my previous comments, please use the updated diff.

eNV25 commented on 2021-04-17 18:14

~~No need for me to be co-maintainer. I might not have access to internet in the future, so I can't promise anything.~~ Actually, sure you can make me a co-maintainer.

If you're too lazy to do changes manually, you can copy-paste the diff to fixed.diff then git apply fixed.diff. I think this should work, haven't tried it. If you don't see the diff, click "See more".

I've tested these changes myself, but you should take a look yourself, just in case.

xandarnull commented on 2021-04-17 18:01

hmu if you wanna be co-maintainer, i'm too lazy for that s

eNV25 commented on 2021-04-17 17:57

Some improvements:

  • Don't use sudo in PKGBUILD. makepkg doesn't need it. This should fix the issue previously reported by @SameExpert.

  • Don't install to /usr/local/.

  • Instead of symlink just use wrapper script.

  • Add freezer-appimage to conflicts: since it installs to /usr/bin/freezer it conflicts.

  • Don't leave checksums to 'SKIP'. Use updpkgsums script to update all sums automatically.

  • Populate depends. I've guessed the dependencies from dpkg -I here, but you should check with the developer if these are right.

  • Use private variable (like $_pkgname_) for the canonical name. (It's not too important, it's just a useful convention.)

  • Why are you installing the desktop file to $HOME/Desktop. Don't do that. Don't touch user's directories.


https://gist.github.com/eNV25/84e0fb22d41263cc62f44375e2a551b3/raw/6b19cc4b3036fdb70a4202edfcb63917f32fb33a/freezer-bin.diff

SameExpert commented on 2021-04-02 14:46

Pamac gives this error:

==> Entering fakeroot environment...
==> Starting package()...
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded > (cannot open shared object file): ignored.
sudo: a terminal is required to read the password; either use the -S option to read from standard input or configure an askpass helper
sudo: a password is required
==> ERROR: A failure occurred in package().
    Aborting...

csts commented on 2021-03-21 04:13

Seized: https://git.rip/freezer