Package Details: freetype2-git 1:2.11.0+p0+g801cd842e-2

Git Clone URL: https://aur.archlinux.org/freetype2-git.git (read-only, click to copy)
Package Base: freetype2-git
Description: Font rasterization library (from git)
Upstream URL: https://www.freetype.org/
Licenses: GPL
Conflicts: freetype2
Provides: freetype2=2.11.0+p0+g801cd842e, libfreetype.so
Submitter: heftig
Maintainer: heftig
Last Packager: heftig
Votes: 8
Popularity: 0.000000
First Submitted: 2012-11-28 14:32
Last Updated: 2021-07-23 22:01

Required by (898)

Sources (8)

Latest Comments

1 2 3 Next › Last »

katt commented on 2021-07-25 22:32

Fails to build when building it a second time:

==> Starting prepare()...
Requirement already satisfied: docwriter in ./docwriter-venv/lib/python3.9/site-packages (1.3.2)
Requirement already satisfied: mkdocs==1.2.1 in ./docwriter-venv/lib/python3.9/site-packages (from docwriter) (1.2.1)
Requirement already satisfied: PyYAML==5.4.1 in ./docwriter-venv/lib/python3.9/site-packages (from docwriter) (5.4.1)
Requirement already satisfied: mkdocs-material==7.1.9 in ./docwriter-venv/lib/python3.9/site-packages (from docwriter) (7.1.9)
Requirement already satisfied: mistune==0.8.4 in ./docwriter-venv/lib/python3.9/site-packages (from docwriter) (0.8.4)
Requirement already satisfied: click>=3.3 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (8.0.1)
Requirement already satisfied: importlib-metadata>=3.10 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (4.6.1)
Requirement already satisfied: pyyaml-env-tag>=0.1 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (0.1)
Requirement already satisfied: Jinja2>=2.10.1 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (3.0.1)
Requirement already satisfied: Markdown>=3.2.1 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (3.3.4)
Requirement already satisfied: packaging>=20.5 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (21.0)
Requirement already satisfied: mergedeep>=1.3.4 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (1.3.4)
Requirement already satisfied: ghp-import>=1.0 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (2.0.1)
Requirement already satisfied: watchdog>=2.0 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs==1.2.1->docwriter) (2.1.3)
Requirement already satisfied: Pygments>=2.4 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs-material==7.1.9->docwriter) (2.9.0)
Requirement already satisfied: mkdocs-material-extensions>=1.0 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs-material==7.1.9->docwriter) (1.0.1)
Requirement already satisfied: pymdown-extensions>=7.0 in ./docwriter-venv/lib/python3.9/site-packages (from mkdocs-material==7.1.9->docwriter) (8.2)
Requirement already satisfied: python-dateutil>=2.8.1 in ./docwriter-venv/lib/python3.9/site-packages (from ghp-import>=1.0->mkdocs==1.2.1->docwriter) (2.8.2)
Requirement already satisfied: zipp>=0.5 in ./docwriter-venv/lib/python3.9/site-packages (from importlib-metadata>=3.10->mkdocs==1.2.1->docwriter) (3.5.0)
Requirement already satisfied: MarkupSafe>=2.0 in ./docwriter-venv/lib/python3.9/site-packages (from Jinja2>=2.10.1->mkdocs==1.2.1->docwriter) (2.0.1)
Requirement already satisfied: pyparsing>=2.0.2 in ./docwriter-venv/lib/python3.9/site-packages (from packaging>=20.5->mkdocs==1.2.1->docwriter) (2.4.7)
Requirement already satisfied: six>=1.5 in ./docwriter-venv/lib/python3.9/site-packages (from python-dateutil>=2.8.1->ghp-import>=1.0->mkdocs==1.2.1->docwriter) (1.16.0)
patching file modules.cfg
patching file include/freetype/config/ftoption.h
patching file include/freetype/config/ftoption.h
patching file include/freetype/config/ftoption.h
patching file builds/meson/generate_reference_docs.py
patching file meson.build
ln: failed to create symbolic link '../freetype-demos/subprojects/freetype2/.': File exists
==> ERROR: A failure occurred in prepare().
    Aborting...

heftig commented on 2021-05-27 21:22

It's already enabled here and in the normal freetype2 package. You can configure it in /etc/profile.d/freetype2.sh

tornado99 commented on 2021-05-27 21:08

I want to compile in the v38 interpreter (Infinality) and use it. How can I modify the PKGBUILD to do this? or is it already compiled in?

heftig commented on 2021-01-29 23:55

As is normal for -git packages, the package will always build the latest HEAD. It only requires an update when something else needs to change.

tornado99 commented on 2021-01-29 23:45

Why does this lag the freetype build number on gitlab? I built this just now and it used the 10th of Jan commit (o3ceda97).

pie3 commented on 2020-06-27 00:54

cflags-order.patch is obsolete now

heftig commented on 2019-08-03 02:08

It's just there to be able to test the old engines in the demos.

shoober420 commented on 2019-08-03 01:51

Hey, is there any reason to have the “enable old engines but keep adobe as default” patch? It’s not included in the main freetype repo, and it’s been updated more recently than this one as of now.

shoober420 commented on 2018-11-13 23:15

Great job! Thanks heftig!

amoka commented on 2018-11-08 16:05

@heftig Works fine now. Thanks!