Package Details: freeorion 0.4.9-1

Git Clone URL: https://aur.archlinux.org/freeorion.git (read-only, click to copy)
Package Base: freeorion
Description: Turn-based space empire and galactic conquest (4X) computer game
Upstream URL: http://www.freeorion.org/
Keywords: freeorion game
Licenses: GPL2
Conflicts: freeorion-git
Provides: freeorion
Submitter: wookietreiber
Maintainer: ragouel
Last Packager: ragouel
Votes: 12
Popularity: 0.77
First Submitted: 2016-03-18 00:15
Last Updated: 2020-02-15 14:20

Latest Comments

1 2 Next › Last »

Heterology commented on 2020-01-26 19:38

I was able to fix the boost_signals issue via the following:

  • Grabbing the latest 0.4.9 release candidate build
  • Editing the package build file to point to the new file
  • Modifying the path to the new unzipped path of the source code

Grab the tarball

> wget https://github.com/freeorion/freeorion/archive/v0.4.9-rc2.tar.gz

Get the hash (for the package config)

> md5sum v0.4.9-rc2.tar.gz 
3f3bdffda5cb09e2f422bff082697df7  v0.4.9-rc2.tar.gz

Modify the package config by updating the URL, hash, and point the src-tarball path fragment to be freeorion-0.4.9-rc2 instead.

I'm sure that once the release is finalized, then the Boost issue will be fixed. :)

rafaelff commented on 2019-09-24 01:26

Boost's component 'signals' was deprecated in version boost 1.54, and such component is not available in current boost version (1.69.0) of the Arch Linux package. However, freeorion is still implemented to use 'signals'. The newer version of signals, the 'signals2', is not compatible with freeorion yet.

Some deprecation note: https://www.boost.org/users/history/version_1_54_0.html#version_1_54_0.news.signals_deprecated

See work in progress in freeorion: https://github.com/freeorion/freeorion/pull/2310

c4v4 commented on 2019-08-31 03:26

three lines down things went bad

-- Found Threads: TRUE
-- Found PythonInterp: /usr/bin/python2.7 (found suitable version "2.7.16", minimum required is "2.7") -- Found PythonLibs: /usr/lib/libpython2.7.so (found suitable version "2.7.16", minimum required is "2.7") CMake Error at /usr/share/cmake-3.15/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find Boost (missing: signals) (found suitable version "1.69.0", minimum required is "1.58.0") Call Stack (most recent call first): /usr/share/cmake-3.15/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.15/Modules/FindBoost.cmake:2142 (find_package_handle_standard_args) CMakeLists.txt:198 (find_package)

-- Configuring incomplete, errors occurred! See also "/var/tmp/pamac-build-nano/freeorion/src/src-tarball/build/CMakeFiles/CMakeOutput.log". See also "/var/tmp/pamac-build-nano/freeorion/src/src-tarball/build/CMakeFiles/CMakeError.log".

account commented on 2019-04-25 00:05

@wookietreiber pacman -Sy is dangerous, so I did pacman -Syu instead. It had nothing to do; I'm up to date. However, now when I try to build the package, I get:

...

-- Could NOT find cppcheck (missing: CPPCHECK_EXECUTABLE) 
-- Could NOT find pycodestyle (missing: PYCODESTYLE_EXECUTABLE) 
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) 
-- Configuring incomplete, errors occurred!
See also "/var/tmp/pamac-build-account/freeorion/src/src-tarball/build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/pamac-build-account/freeorion/src/src-tarball/build/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
    Aborting...

wookietreiber commented on 2019-04-23 06:37

@account: This has nothing to do with the freeorion PKGBUILD. I guess, you just need to refresh your package database: pacman -Sy.

account commented on 2019-04-22 23:32

I can't install, getting the error:

failed retrieving file 'boost-1.69.0-1-x86_64.pkg.tar.xz' from kartolo.sby.datautama.net.id : The requested URL returned error: 404 Not Found

wookietreiber commented on 2018-03-31 12:41

@altjsus: Do you know which patch (or commit or pull request) might have fixed the issue?

I'm willing to add the specific patches needed to get it working. I'm not willing, though, to find out by myself what individual commits or pull request are needed for that.

altjsus commented on 2018-03-26 10:15

I had a problem with this package. After few minutes of playing it kicks me out of the game and I can't load any saving. Installing from (github) source fixed this.

wookietreiber commented on 2018-02-17 10:27

@cassfalg done, thanks for letting me know about the patch

cassfalg commented on 2018-02-06 08:25

There's an issue with boost 1.66 which needs a fix backported, this is the commit that did it / way to the diff: git diff c9b5b13fb81b1ed142dee0e843101c6b8832ca95^ c9b5b13fb81b1ed142dee0e843101c6b8832ca95 It's just 2 lines changed, maybe you can add a patch to the package?