Package Details: freefem 4.6-1

Git Clone URL: https://aur.archlinux.org/freefem.git (read-only, click to copy)
Package Base: freefem
Description: A PDE oriented language using the finite element method
Upstream URL: https://freefem.org/index.html
Licenses: LGPL
Conflicts: freefem++
Provides: freefem++
Submitter: haawda
Maintainer: Sosthene
Last Packager: Sosthene
Votes: 15
Popularity: 0.29
First Submitted: 2019-06-19 19:31
Last Updated: 2020-04-02 14:33

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 Next › Last »

holos commented on 2012-11-14 22:04

yaourt is probably automatically downloading umfpack for suitesparse. Read lazork's comment. Use makepkg.

holos commented on 2012-11-14 22:03

makepkg -si

mrbit commented on 2012-11-14 13:05

make[3]: Entering directory `/tmp/yaourt-tmp-root/aur-freefem/src/freefem++-3.20/src/x11'
g++ -DHAVE_CONFIG_H -I. -I../.. -I./../fflib -I./../Graphics -I./../.. -I./../femlib -march=x86-64 -mtune=generic -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -DNDEBUG -O3 -mmmx -msse -msse2 -DBAMG_LONG_LONG -DNCHECKPTR -fPIC -MT Xrgraph.o -MD -MP -MF .deps/Xrgraph.Tpo -c -o Xrgraph.o `test -f '../Graphics/Xrgraph.cpp' || echo './'`../Graphics/Xrgraph.cpp
mv -f .deps/Xrgraph.Tpo .deps/Xrgraph.Po
g++ -DHAVE_CONFIG_H -I. -I../.. -I./../fflib -I./../Graphics -I./../.. -I./../femlib -march=x86-64 -mtune=generic -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -DNDEBUG -O3 -mmmx -msse -msse2 -DBAMG_LONG_LONG -DNCHECKPTR -fPIC -MT parallelempi-empty.o -MD -MP -MF .deps/parallelempi-empty.Tpo -c -o parallelempi-empty.o `test -f '../mpi/parallelempi-empty.cpp' || echo './'`../mpi/parallelempi-empty.cpp
mv -f .deps/parallelempi-empty.Tpo .deps/parallelempi-empty.Po
g++ -march=x86-64 -mtune=generic -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -DNDEBUG -O3 -mmmx -msse -msse2 -DBAMG_LONG_LONG -DNCHECKPTR -fPIC -Wl,-O1,--sort-common,--as-needed,-z,relro -rdynamic -o FreeFem++-x11 Xrgraph.o parallelempi-empty.o ../lglib/liblg.a ../fflib/libff.a -lumfpack -lamd -larpack -llapack -lblas -lXxf86vm -lXext -lX11 -lXpm -lm -ldl /usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../libgfortran.so
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umfpack_gn_tictoc.o): nella funzione "umfpack_tic":
(.text+0x5): riferimento non definito a "SuiteSparse_time"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umfpack_gn_tictoc.o): nella funzione "umfpack_toc":
(.text+0x25): riferimento non definito a "SuiteSparse_time"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): nella funzione "umf_i_cholmod":
(.text+0x9e): riferimento non definito a "cholmod_start"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): nella funzione "umf_i_cholmod":
(.text+0x1cd): riferimento non definito a "cholmod_analyze"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): nella funzione "umf_i_cholmod":
(.text+0x1e4): riferimento non definito a "cholmod_free_sparse"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): nella funzione "umf_i_cholmod":
(.text+0x298): riferimento non definito a "cholmod_free_factor"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): nella funzione "umf_i_cholmod":
(.text+0x2b1): undefined reference to "cholmod_print_common"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): nella funzione "umf_i_cholmod":
(.text+0x2be): undefined reference to "cholmod_finish"
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libumfpack.a(umf_i_cholmod.o): in the function "umf_i_cholmod":
(.text+0x440): undefined reference to "cholmod_transpose"
collect2: error: ld returned 1 exit status
make[3]: *** [FreeFem++-x11] Errore 1

holos commented on 2012-11-14 01:02

fixed

mrbit commented on 2012-11-14 00:22

error build

holos commented on 2012-11-11 19:15

I wrote the PKGBUILD with the ++ elsewhere so now there are two packages, freefem and freefem++. Thanks to lazork for the tip.

haawda commented on 2012-11-01 21:01

The package has no maintainer, so you can easily update it yourself. If you do not want to maintain it, just orphan it again after uploading.

lgpasquale commented on 2012-11-01 20:47

I need to remove umfpack from the list of dependencies to be able to compile.
umfpack installs the latest version of suitesparse which I believe is not compatible with freefem.
Better let freefem download its own version of suitesparse (which it will do, since it's using the option --enable-download).
Btw, this PKGBUILD works with version 3.20 as well; just edit the version and the md5sum

Anonymous comment on 2012-05-27 17:45

> add patch
Is it still needed? Well, added.

mrbit commented on 2012-05-27 05:50