Package Details: freecad-appimage 0.18_16146-1

Git Clone URL: https://aur.archlinux.org/freecad-appimage.git (read-only, click to copy)
Package Base: freecad-appimage
Description: A general purpose 3D CAD modeler (binary AppImage version)
Upstream URL: http://www.freecadweb.org/
Licenses: LGPL
Conflicts: freecad
Provides: freecad=0.18.4
Submitter: igormp
Maintainer: igormp
Last Packager: igormp
Votes: 15
Popularity: 0.049731
First Submitted: 2019-01-04 10:42
Last Updated: 2019-12-03 20:44

Pinned Comments

Chryseus commented on 2020-04-12 11:45

If anyone is getting a 'sqfs_traverse_open error' it means the download is corrupt (apparently a common issue with github), rather than download it all again you can fix it with the appimage updater available on the freecad wiki.

Latest Comments

1 2 3 Next › Last »

Kunda commented on 2020-10-29 12:32

curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://github.com/FreeCAD/FreeCAD/releases/download/0.18.4/FreeCAD_0.18-16146-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage
    Aborting...
Failed to build freecad-appimage

jonnor commented on 2020-06-06 18:31

In case anyone gets crashes when opening a document, and output like the following in the console:

libGL error: MESA-LOADER: failed to open iris (search paths /usr/lib/dri) libGL error: failed to load driver: iris libGL error: MESA-LOADER: failed to open iris (search paths /usr/lib/dri) libGL error: failed to load driver: iris libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib/dri) libGL error: failed to load driver: swrast Program received signal SIGSEGV, Segmentation fault.

0 /usr/lib/libc.so.6(+0x3c3e0) [0x7f7658a6d3e0]
1 /usr/lib/libc.so.6(+0x16400e) [0x7f7658b9500e]
2 /tmp/.mount_freecaXe4ulM/usr/bin/../lib/libCoin.so.4.0.0(cc_glglue_instance+0x14c) [0x7f765c19a71c]
3 0x7f765bffbe60 in SoGLRenderActionP::isDirectRendering(SoState const*) const from /tmp/.mount_freecaXe4ulM/usr/bin/../lib/libCoin.so.4.0.0+0x40

Then the issue might be fixable with the following, which makes the libGL drivers load again:

LD_PRELOAD=/usr/lib/libstdc++.so.6 freecad

Of course also check that your libGL is generally working, for example using glxinfo/glxgears

Chryseus commented on 2020-04-12 11:45

If anyone is getting a 'sqfs_traverse_open error' it means the download is corrupt (apparently a common issue with github), rather than download it all again you can fix it with the appimage updater available on the freecad wiki.

igormp commented on 2019-12-26 17:46

@nTia89 I can't reproduce this error by any means, nor can find something related online. Maybe that's something to do with AppImage?

nTia89 commented on 2019-12-12 20:21

I get this error during package prepare(): sqfs_traverse_open error Any help is welcome...

igormp commented on 2019-12-03 20:50

Hi there, sorry for the long time to update, but I finally found time to do it.

Special thanks to @mudkip908 and @dviktor for the patches!

dviktor commented on 2019-11-29 14:57

Please update. Here is also one improvement to better track new versions:

--- PKGBUILD.old    2019-08-28 14:47:09.000000000 +0300
+++ PKGBUILD    2019-11-29 17:53:29.369229138 +0300
@@ -1,23 +1,24 @@
 # Maintainer: Igor Moura <imp2@cin.ufpe.br>

 pkgname=freecad-appimage
-pkgver=0.18_16131
+pkgver=0.18_16146
+_pkgver=0.18.4
 pkgrel=1
 pkgdesc="A general purpose 3D CAD modeler (binary AppImage version)"
 arch=('x86_64')
 url='http://www.freecadweb.org/'
 license=('LGPL')
 depends=('fuse2')
-provides=('freecad')
+provides=("freecad=${_pkgver}")
 conflicts=('freecad')
-source=("https://github.com/FreeCAD/FreeCAD/releases/download/0.18.3/FreeCAD_${pkgver//_/-}-Linux-Conda_Py3Qt5_glibc2.12-${arch}.AppImage"
+source=("https://github.com/FreeCAD/FreeCAD/releases/download/${_pkgver}/FreeCAD_${pkgver//_/-}-Linux-Conda_Py3Qt5_glibc2.12-${arch}.AppImage"
         freecad_conda.desktop.patch
         freecad.sh)
-sha256sums=(SKIP
-         'c56c0d1fd1d795419e464e487bab5fe2f62edb3ce40f895079d8251a9f6ddd1b'
-         '9bfca97e1e633601ddfbd74f32501050f50378cfd6b30f5bf91d978e7ce33436')
+sha256sums=('75ca62ee7dc405c052d370892f79a4d18f4ce5d12614474bc45b11b9dc0e2d50'
+            'c56c0d1fd1d795419e464e487bab5fe2f62edb3ce40f895079d8251a9f6ddd1b'
+            '9bfca97e1e633601ddfbd74f32501050f50378cfd6b30f5bf91d978e7ce33436')
 options=(!strip)
 _filename=./FreeCAD_${pkgver//_/-}-Linux-Conda_Py3Qt5_glibc2.12-${arch}.AppImage

 prepare() {
   cd "${srcdir}"

mudkip908 commented on 2019-09-05 01:27

Might I suggest making the script pass through arguments, like

LIBGL_DRI3_DISABLE=true /opt/appimages/freecad.AppImage "$@"

to make opening .FCStd files with file managers work correctly?

edit: it's also necessary to add %F to Exec in the desktop file.

igormp commented on 2019-08-28 11:47

Ok, I've updated it since some users weren't facing any issues.

barabas commented on 2019-08-25 12:51

Hi. I have no issues when running the AppImage. Both the version in this package and the most recent version from the website run with no issues. (FreeCAD_0.18-16131-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage)

According to this thread, 0.19 will fix the issue.