Package Details: forge-server-1.12.2 1.12.2_14.23.5.2768-2

Git Clone URL: https://aur.archlinux.org/forge-server-1.12.2.git (read-only)
Package Base: forge-server-1.12.2
Description: Minecraft Forge server unit files, script, and jar
Upstream URL: https://minecraftforge.net/
Keywords: bash forge minecraft minecraft-server script server
Licenses: custom
Submitter: Nitroretro
Maintainer: Nitroretro
Last Packager: Nitroretro
Votes: 1
Popularity: 0.29
First Submitted: 2019-09-17 19:08
Last Updated: 2019-09-22 00:32

Required by (0)

Sources (9)

Pinned Comments

Nitroretro commented on 2019-09-17 19:20

Main package and help: forge-server

Use forge-1.12.2d instead of forged. The user it creates is called forge-1-12-2.

Latest Comments

Romain commented on 2019-10-19 12:24

Hi @Nitroretro !

Thank you for your comment ! Actually that's kind of what I did and it worked perfectly fine ! It was my first time modifying a package but it was simpler than I thought so I figured it out. I should have updated my comment, sorry.

Anyway, thank you for the package and for your kind explanations !

Nitroretro commented on 2019-10-12 20:26

Hey @Romain. This package is made to work with the recommended version of Forge (currently 14.23.5.2768), but you can really use any version you want with it.

Let's say you want to use the latest version, which is 14.23.5.2847 at the time of writing. All you have to do is edit the _pkgver variable inside the PKGBUILD file, like this:

diff:

12c12
< _pkgver=${_minecraft_ver}-14.23.5.2768
---
> _pkgver=${_minecraft_ver}-14.23.5.2847

Next, you have to update the checksums. For more information on how to do this, read PKGBUILD#Integrity over on the ArchWiki. Alternatively, use the --skipchecksums option with makepkg to skip this process entirely.

When you update the package, it will just delete the old version and keep your save data, so you don't have to worry about anything. I don't recommend swapping out the old .jar with a new one as there might be some issues regarding the libraries.

If you have any doubts, feel free to ask.

Romain commented on 2019-10-12 13:20

Hi !

Is there a way to update our forge server easily ? For example, if I change my jar file to an updated version of forge 1.12.2 will it work ? Or is it better to update this whole package and reinstall it ?

Thanks !

Nitroretro commented on 2019-09-17 19:20

Main package and help: forge-server

Use forge-1.12.2d instead of forged. The user it creates is called forge-1-12-2.