Package Details: flyctl-bin 0.0.225-1

Git Clone URL: https://aur.archlinux.org/flyctl-bin.git (read-only, click to copy)
Package Base: flyctl-bin
Description: Command line tools for fly.io services
Upstream URL: https://fly.io
Licenses: Apache
Conflicts: flyctl
Provides: flyctl
Submitter: jeromegn
Maintainer: jeromegn
Last Packager: jeromegn
Votes: 2
Popularity: 0.38
First Submitted: 2020-04-16 22:15
Last Updated: 2021-06-11 18:04

Dependencies (0)

Required by (0)

Sources (1)

Latest Comments

jeromegn commented on 2021-02-04 15:11

@unixfox: this should be fixed now. Our envsubst call was replacing too many variables that looked like env vars

unixfox commented on 2021-02-04 09:19

For some unknown reason it doesn't want to build anymore:

:: Starting the build:
==> Making package: flyctl-bin 0.0.172-1 (Thu 04 Feb 2021 10:18:46 AM CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading -0.0.172.tgz...
Warning: The file name argument '-0.0.172.tgz.part' looks like a flag.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   642  100   642    0     0   2147      0 --:--:-- --:--:-- --:--:--  2147
100 13.7M  100 13.7M    0     0  4832k      0  0:00:02  0:00:02 --:--:-- 5538k
==> Validating source files with sha256sums...
    -0.0.172.tgz ... Passed
==> Extracting sources...
  -> Extracting -0.0.172.tgz with bsdtar
==> Entering fakeroot environment...
==> Starting package()...
install: cannot create regular file '/usr/bin/flyctl': Permission denied
==> ERROR: A failure occurred in package().

EDIT: I found the issue you need to add $pkgdir before /usr/bin. You removed it in commit 87d6a7c036e1

jeromegn commented on 2021-02-03 14:07

I've made this a part of our release workflow. It shouldn't get outdated as often anymore.