Package Details: fluxgui 1.2.0-3

Git Clone URL: https://aur.archlinux.org/fluxgui.git (read-only)
Package Base: fluxgui
Description: Better lighting for Linux. Open source GUI for xflux
Upstream URL: https://justgetflux.com/
Keywords: bluelight eye-strain indicator-applet night sleep-issues xflux
Licenses: MIT
Conflicts: xflux, xflux-gui-git
Provides: fluxgui
Submitter: ValHue
Maintainer: oguzkagan (alaskanarcher)
Last Packager: oguzkagan
Votes: 8
Popularity: 0.56
First Submitted: 2018-02-13 17:17
Last Updated: 2019-11-18 16:59

Latest Comments

alaskanarcher commented on 2019-11-17 19:27

The PKGBUILD misses some depends and makedepends for building in a clean chroot.

depends needs python

makedepends needs wget

Consider adding the file being fetched during build() to be listed in the sources directly so that makepkg can fetch it and verify a checksum on the file.

hcra commented on 2019-11-14 09:11

Thanks for the update! Here it seems fluxgui uses python3 and I had to install the packages python-pexpect python-xdg afterwards. I guess this applies for all python2 dependencies. Before the update I had to remove the icons manually because there were an error that this files can't overwritten.

rm -r /usr/lib/python3.7/site-packages/fluxgui /usr/share/glib-2.0/schemas/apps.fluxgui.gschema.xml /usr/share/icons/Adwaita/16x16/status/fluxgui-panel.svg /usr/share/icons/breeze-dark/status/22/fluxgui-panel.svg /usr/share/icons/breeze/status/22/fluxgui-panel.svg /usr/share/icons/elementary-xfce-dark/panel/22/fluxgui-panel.svg /usr/share/icons/elementary-xfce/panel/22/fluxgui-panel.svg /usr/share/icons/elementary/status/24/fluxgui-panel.svg /usr/share/icons/hicolor/16x16/apps/fluxgui.svg /usr/share/icons/hicolor/22x22/apps/fluxgui.svg /usr/share/icons/hicolor/24x24/apps/fluxgui.svg /usr/share/icons/hicolor/32x32/apps/fluxgui.svg /usr/share/icons/hicolor/48x48/apps/fluxgui.svg /usr/share/icons/hicolor/64x64/apps/fluxgui.svg /usr/share/icons/hicolor/96x96/apps/fluxgui.svg /usr/share/icons/ubuntu-mono-dark/status/16/fluxgui-panel.svg /usr/share/icons/ubuntu-mono-dark/status/22/fluxgui-panel.svg /usr/share/icons/ubuntu-mono-dark/status/24/fluxgui-panel.svg /usr/share/icons/ubuntu-mono-light/status/16/fluxgui-panel.svg /usr/share/icons/ubuntu-mono-light/status/22/fluxgui-panel.svg /usr/share/icons/ubuntu-mono-light/status/24/fluxgui-panel.svg

oguzkagan commented on 2019-11-14 07:59

@gbc921 Thanks. I updated the package.

gbc921 commented on 2019-07-28 06:09

Hi ljmf00,

I updated the PKGBUILD to the new version (1.2.0), changing to python3 and including a new missing dependency: https://github.com/gbc921/aur/blob/master/done/fluxgui/PKGBUILD

I am not sure if new deps are needed as I may have them installed previously. Also, some of the old deps may be removed but I did not test. Flux is working fine for me with the newest version.

Tks

ViAik commented on 2019-07-09 00:27

Currently can confirm the bug presented by @alaskanarcher. After running fluxgui and clicking OK at the ZIP/latitude prompt, the program exits with the same error. Can't install xflux manually since it's apparently a conflict with fluxgui, even though fluxgui doesn't seem to install xflux by itself.

alaskanarcher commented on 2019-06-11 09:26

When I build this in a clean chroot it succeeds but does not work when run. I get the error:

$ fluxgui 

Error: Please install xflux in the PATH 

Critical error. Exiting.
Traceback (most recent call last):
  File "/usr/bin/fluxgui", line 20, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/fluxgui/fluxapp.py", line 213, in main
    app = FluxGUI()
  File "/usr/lib/python2.7/site-packages/fluxgui/fluxapp.py", line 28, in __init__
    self.exit(1)
  File "/usr/lib/python2.7/site-packages/fluxgui/fluxapp.py", line 46, in exit
    gtk.main_quit()
RuntimeError: called outside of a mainloop

When I build on my normal system, outside of a clean chroot. fluxgui launches without issue.

renexe89 commented on 2019-04-13 01:16

Confirmed to work in Manjaro XCFE 4.13

dzaragoza commented on 2019-03-16 22:37

Missing dependencies python-gobject and libappindicator-gtk3