Package Details: flightgear-git 2020.4.0r15376.4e432b3f8-1

Git Clone URL: https://aur.archlinux.org/flightgear-git.git (read-only, click to copy)
Package Base: flightgear-git
Description: An open-source, multi-platform flight simulator
Upstream URL: https://home.flightgear.org
Licenses: GPL
Conflicts: flightgear
Provides: flightgear=2020.4.0r15376.4e432b3f8
Submitter: pascal
Maintainer: AWhetter (flatwhatson)
Last Packager: flatwhatson
Votes: 13
Popularity: 0.003919
First Submitted: 2010-07-24 14:22
Last Updated: 2021-05-02 10:16

Latest Comments

1 2 Next › Last »

flatwhatson commented on 2021-05-02 10:17

@dreieck Done, thanks for the help!

dreieck commented on 2021-05-02 10:05

git needs to be added to the makedepends.

Thanks for maintaining!

dreieck commented on 2021-05-02 09:44

Can you change provides=('flightgear') to provides=("flighgear=${pkgver}")?

@Woodhousezb: I get 2020.4*-version.

Thanks for maintaining!

Woodhousezb commented on 2021-01-31 11:34

Yesterday building this produced a 2020.4 version. Building today gives a 2020.3 version, and thus a downgrade?

flatwhatson commented on 2020-10-13 11:53

@Woodhousezb I think you need to update your simgear-git before building this one.

Woodhousezb commented on 2020-10-13 11:33

I am now getting another Error further down the line and compile will not finish:


/var/tmp/pamac-build-melle/flightgear-git/src/flightgear/src/Scripting/NasalSys.cxx: In function ‘naRef f_print(naContext, naRef, int, naRef)’:
/var/tmp/pamac-build-melle/flightgear-git/src/flightgear/src/Scripting/NasalSys.cxx:539:41: error: ‘SG_MANDATORY_INFO’ was not declared in this scope
  539 |         if (sglog().would_log(SG_NASAL, SG_MANDATORY_INFO)) {
      |                                         ^~~~~~~~~~~~~~~~~
In file included from /usr/include/simgear/props/props.hxx:34,
                 from /var/tmp/pamac-build-melle/flightgear-git/src/flightgear/src/Scripting/NasalSys.cxx:38:
/var/tmp/pamac-build-melle/flightgear-git/src/flightgear/src/Scripting/NasalSys.cxx:554:26: error: ‘SG_MANDATORY_INFO’ was not declared in this scope
  554 |         SG_LOG(SG_NASAL, SG_MANDATORY_INFO, buf);
      |                          ^~~~~~~~~~~~~~~~~
/var/tmp/pamac-build-melle/flightgear-git/src/flightgear/src/Scripting/NasalSys.cxx: In member function ‘void FGNasalSys::initLogLevelConstants()’:
/var/tmp/pamac-build-melle/flightgear-git/src/flightgear/src/Scripting/NasalSys.cxx:1060:47: error: ‘SG_MANDATORY_INFO’ was not declared in this scope
 1060 |     hashset(_globals, "MANDATORY_INFO", naNum(SG_MANDATORY_INFO));
      |                                               ^~~~~~~~~~~~~~~~~
[ 75%] Building CXX object src/Main/CMakeFiles/fgfs.dir//Scripting/NasalString.cxx.o
[ 75%] Building CXX object src/Main/CMakeFiles/fgfs.dir//Scripting/NasalModelData.cxx.o
[ 75%] Building CXX object src/Main/CMakeFiles/fgfs.dir//Scripting/NasalSGPath.cxx.o
[ 75%] Building CXX object src/Main/CMakeFiles/fgfs.dir//Scripting/NasalUnitTesting.cxx.o
make[2]:  [src/Main/CMakeFiles/fgfs.dir/build.make:3748: src/Main/CMakeFiles/fgfs.dir/__/Scripting/NasalSys.cxx.o] Error 1
make[2]: ** Waiting for unfinished jobs....
make[1]:  [CMakeFiles/Makefile2:3505: src/Main/CMakeFiles/fgfs.dir/all] Error 2
make: *** [Makefile:182: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

PCITechie commented on 2020-08-05 17:08

Openscenegraph34 does not exist in the AUR nor in the official repos as far as i can tell. I have requested the simgear-git maintainers fix this. For now before building just edit the simgear-git PKGBUILD manually.

acxz commented on 2020-01-18 01:46

I cannot install this package, error:

==> Error: Could not find all required packages:
    openscenegraph34 (Wanted by: flightgear-git)
    openscenegraph34 (Wanted by: flightgear-git -> simgear-git)

GDsouza commented on 2019-10-13 20:42

@satscape: You need to patch some weirdness with Boost. There's a working copy here >> https://github.com/GDsouza/PKGBUILDS

satscape commented on 2019-10-13 17:59

-- Found Boost: /usr/lib64/cmake/Boost-1.71.0/BoostConfig.cmake (found version "1.71.0")
CMake Error at CMakeModules/BoostTestTargets.cmake:55 (message): NOTE: boost::test-based targets and tests cannot be added: boost >= 1.34.0 required but not found. (found: '1.71.0' want >=103400) You may disable ENABLE_TESTS to continue without the tests. Call Stack (most recent call first): CMakeLists.txt:222 (include)

-- Configuring incomplete, errors occurred! See also "/home/scott/.cache/yay/simgear-git/src/simgear/CMakeFiles/CMakeOutput.log". See also "/home/scott/.cache/yay/simgear-git/src/simgear/CMakeFiles/CMakeError.log". ==> ERROR: A failure occurred in build(). Aborting... Error making: simgear-git