Package Details: flatcam 8.5-1

Git Clone URL: https://aur.archlinux.org/flatcam.git (read-only, click to copy)
Package Base: flatcam
Description: Generates CNC gcode from 2D PCB files (Gerber/Excellon/SVG). Most recent, stable version (non-beta) from master branch
Upstream URL: http://flatcam.org
Licenses: MIT
Submitter: Jake
Maintainer: Jake (matthew798)
Last Packager: matthew798
Votes: 5
Popularity: 0.133144
First Submitted: 2016-02-13 21:46
Last Updated: 2020-07-25 22:08

Pinned Comments

matthew798 commented on 2020-05-07 02:02

There is a bug in matplotlib that will prevent flatcam from launching.

To fix: 1) Open /usr/lib/python3.8/site-packages/matplotlib/backends/qt_compat.py 2) Add "_isdeleted" to line 95. It should look like:

def _setup_pyqt4_internal(api):
    global QtCore, QtGui, QtWidgets, \
        __version__, _isdeleted, is_pyqt5, _getSaveFileName

This won't be an issue when the next minor version of matplotlib is released.

Latest Comments

matthew798 commented on 2020-07-25 22:09

@r2d2 Thanks for pointing that out! It is fixed.

r2d2 commented on 2020-07-20 16:29

This package is missing a dependency on PyQt4.

flatcam
Traceback (most recent call last):
  File "/opt/flatcam/flatcam", line 11, in <module>
    from PyQt4 import QtGui
ModuleNotFoundError: No module named 'PyQt4'

matthew798 commented on 2020-05-07 02:02

There is a bug in matplotlib that will prevent flatcam from launching.

To fix: 1) Open /usr/lib/python3.8/site-packages/matplotlib/backends/qt_compat.py 2) Add "_isdeleted" to line 95. It should look like:

def _setup_pyqt4_internal(api):
    global QtCore, QtGui, QtWidgets, \
        __version__, _isdeleted, is_pyqt5, _getSaveFileName

This won't be an issue when the next minor version of matplotlib is released.

Jake commented on 2020-05-06 23:06

Alright, i have added you as maintainer @matthew798. Feel free to push your PKGBUILD.

matthew798 commented on 2020-05-06 20:13

@Jake yeah I'd love to co-maintain! Though master hasn't been updated for a long time, it is the only stable, working and feature complete version available. I have had a lot of difficulties getting the beta version to generate GCODE for my boards. It either crashes or isn't clear in the values it's expecting.

IMO This package should install the last non-beta version of flatcam, and the flatcam-git package can stay as is. This way, users have a choice of which version they use.

Jake commented on 2020-05-06 18:08

@matthew798: Master also did not get updates for almost 2 years (last commits are only for the ubuntu script) though. Does it really work better than the Beta? It still needs QT4 from AUR, which is a bit annoying. But I think it would be at least better than the current state here, with the missing python2 deps... Are you actually using it and would you be interested in (co)maintaining this?

matthew798 commented on 2020-05-04 04:23

Hi jake. Can you re-work this package to install the master branch? You are correct that development has moved to the beta branch, but is is buggy and is, after all, beta. The master branch has the last working version of the original creator and would be useful to still have access to.

Specifically, commit dae9cbb0471e693b95fd809ddd8bf11ff026ac67 works well.

This version was upgraded to python 3 so you'll need to re-work the deps. I put together a PKGBUILD, let me know if you'd like me to send it to you.

One note is that python-matplotlib has a bug where the user will have to edit one of the files but IIRC it will be fixed in the next minor release.

Jake commented on 2019-05-14 10:29

The latest stable (8.5) is from mid 2016. But there was active development in the meantime, so i would strongly recommend using flatcam-git for now, it uses python 3 and has all dependencies available.

Jake commented on 2019-01-09 00:31

@nlufr: Yes, done. It is required since they dropped python2-pyqt4 from the repos.

nlufr commented on 2019-01-07 12:23

Can you add python2-sip-pyqt4 to the dependencies. Thank you.