Package Details: flashprint 4.6.2-1

Git Clone URL: https://aur.archlinux.org/flashprint.git (read-only, click to copy)
Package Base: flashprint
Description: Slicer for the FlashForge 3D printers.
Upstream URL: http://www.ff3dp.com/
Keywords: 3d flashforge printer slicer
Licenses: custom
Submitter: froj
Maintainer: mgisbers
Last Packager: mgisbers
Votes: 7
Popularity: 0.145423
First Submitted: 2016-04-19 11:18
Last Updated: 2021-02-06 16:20

Latest Comments

1 2 3 Next › Last »

kaipee2 commented on 2021-01-25 21:36

I've been testing some Beta versions with Flashforge Support, and can confirm one of them works great with nVidia now. No longer crashing when slicing.

Just waiting for the release.

kaipee2 commented on 2021-01-15 17:01

@slexin That package and the one listed in the PKGBUILD are the same

md5sum flashprint_4.6.0_amd64.deb 387ac04a8e8ffce5045d50ff21054a8e.deb > pkg.md5
md5sum -c pkg.md5 
flashprint_4.6.0_amd64.deb: OK
387ac04a8e8ffce5045d50ff21054a8e.deb: OK

The issue seems to be with the nVidia driver.

I can confirm:

  • 4.6.0 works with embedded Intel GPU
  • 4.6.0 crashdumps with nVidia (proprietary) on libGLdispatch.so
  • 4.5.1 works fine with nVidia (proprietary)

If you need to downgrade to 4.5.1

yay -G flashprint
git checkout -b 4.5.1 81472293f027123595fc47bde1fb7beb57be1c26
makepkg -s
sudo pacman -U flashprint-4.5.1-2-x86_64.pkg.tar.zst

selexin commented on 2021-01-09 11:40

I'm getting segfault when attempting to slice (I've tried on STLs that have previously worked), so I just checked http://en.flashforge.com/download-center to see if there is a new version. There was a new release 2021-01-05 - strangely the version number is 4.6.0 (the same version that this package is currently at).

The deb can be found at: https://en.fss.flashforge.com/10000/software/387ac04a8e8ffce5045d50ff21054a8e.deb - the MD5 sum appears the same as the one in the PKGBUILD: 09e751fe9c46aaddad21a663cb532795.

Just thought I'd mention this in case I'm missing something and they have actually released an update under the same version number.

Not sure what the go with the segfault is, the only info I can find in journalctl is:

Stack trace of thread 518601:
#0  0x00007f0cdeb4afc9 n/a (libGLdispatch.so.0 + 0x45fc9)

Edit: I've rolled back to 4.5.1 and everything is working fine. I'm happy to debug 4.6.0 further if someone knows where I can go looking for some logs?

fred118 commented on 2020-12-30 09:51

I have a lot of crashes lately, when accessing the file system. The installed version says it is 4.6.0, 64 bit. But as Chewtoy said, the download site of FlashForge says, the latest version is 4.5.1. Did they withdraw version 4.6.0?

Chewtoy commented on 2020-11-12 20:40

Thanks for the package! Any plans to update it? This currently fails to install as the upstream package no longer exists. They seem to have moved the location for it. https://en.fss.flashforge.com/10000/software/361aa4e2603599ff099e83c8c95f2426.deb seems to be the latest (4.5.1) found here https://www.flashforge.com/download-center

nt661974 commented on 2020-05-18 06:26

libicui.so.65 along with one more .so.65 lib I forgot about. When, you update your system it will no longer work as it will now be on libicui.so.67. This is why we need icu65 from the AUR.

mgisbers commented on 2020-05-17 13:28

@nt661974 which binary/lib forces you to use icu65. Just used flashprint to print without having icu65 installed.

nt661974 commented on 2020-05-16 12:47

We need icu65 from the AUR as a dependency for this now, because the repos' are at version 67 of the icu package.

mgisbers commented on 2020-03-23 10:00

The PKGBUILD now has an dependency on qt5-base-595 and uses the libraries. Thanks to selexin for this workaround.

selexin commented on 2020-03-21 22:24

The segfault is in libQtGui. I suspect that the current version of Flashprint is not compatible with the Qt version of Arch.

I think you're right, I've got it working manually by installing qt5-base-595 from AUR and then starting flashprint like so:

export LD_LIBRARY_PATH=/opt/qt595/lib ; flashprint