Package Details: firehol 2:3.1.6-1

Git Clone URL: https://aur.archlinux.org/firehol.git (read-only, click to copy)
Package Base: firehol
Description: The iptables stateful packet filtering firewall builder.
Upstream URL: http://firehol.sourceforge.net
Keywords: firewall iptables
Licenses: GPL
Submitter: schuay
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 33
Popularity: 1.04
First Submitted: 2013-03-15 14:51
Last Updated: 2018-08-17 20:50

Latest Comments

1 2 3 4 5 Next › Last »

SanskritFritz commented on 2020-01-23 21:15

also https://github.com/firehol/firehol/issues/126

andykluger commented on 2020-01-23 21:09

@t-ask

You shouldn't need to do that. If you post your full output with the problem someone might be able to help, which could also help any other people with your problem.

EDIT: See also: https://github.com/firehol/firehol/issues/389

t-ask commented on 2020-01-23 21:01

Yes, iputils was installed. I did 'fix' it with a small workaround:

# mg /usr/bin/ping6
   #!/bin/bash
   ping -6 $@
# chmod +x /usr/bin/ping6

andykluger commented on 2020-01-23 20:29

@t-ask

Strange, I get

checking for ping... /bin/ping
checking whether PING has working -6 option... yes

with no problems. Do you have iputils installed?

t-ask commented on 2020-01-23 20:21

Trying to install this package I get error:

checking for ping6... no
configure: error: cannot find required executable, bailing out

jsteel commented on 2019-03-18 12:59

OK that is odd, I was building with devtools and believe that pulls in base but I guess not.

SanskritFritz commented on 2019-03-18 12:43

Both are part of the base group which is assumed to be installed although the packaging guidelines don't specify this.

jsteel commented on 2019-03-18 08:49

'procps-ng' 'iputils' are needed as deps, otherwise:

checking for sysctl... no configure: error: cannot find required executable, bailing out

checking for ping... no configure: error: cannot find required executable, bailing out

SanskritFritz commented on 2019-01-13 10:07

I will add screen as an optional dependency. The service files here are provided by upstream, so please file a request to them on github.

twnaing commented on 2019-01-13 08:51

screen is required by link-balancer

please also add link-balancer.service. I am a noob at writing systemd unit file. I am currently using the following systemd unit for link-balancer

[Unit]
Description=Link Balancer for FireHOL
Wants=network-online.target
After=network-online.target

[Service]
Type=oneshot
ExecStart=/sbin/screen -S 'link-balancer' -d -m /sbin/link-balancer loop                                                               
ExecStop=/sbin/screen -S 'link-balancer' -X kill
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target