Package Details: firefox56 56.0.2-2

Git Clone URL: https://aur.archlinux.org/firefox56.git (read-only, click to copy)
Package Base: firefox56
Description: Old version of the standalone web browser from mozilla.org
Upstream URL: https://www.mozilla.org/firefox/
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox
Submitter: Splith
Maintainer: Splith
Last Packager: Splith
Votes: 3
Popularity: 0.000002
First Submitted: 2017-12-01 20:02
Last Updated: 2018-07-06 00:48

Dependencies (32)

Required by (124)

Sources (12)

Latest Comments

1 2 Next › Last »

piussj2 commented on 2020-06-13 05:16

I cannot compile on a current system. Every hour it gives a different error and the compilation stops. I really need this version, because the waterfox, which would be an alternative, does not work with flash, only in versions already compiled, which for me, has no advantage. Any idea?

applebloom commented on 2018-09-22 16:00

Fails to build now, with "Unsupported relocation type" in elf-hack. This is because elf-hack (if I understand correctly, this is some sort of link-time optimizer) doesn't support current LLVM. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1440037

So there are three options:

  1. The FF bug is fixed, and it's a very simple change, so apply this: https://hg.mozilla.org/mozilla-central/rev/afd291850b80
  2. Downgrade llvm (to version 6.0.1, since 7.0.0, the current one, contains the breaking change).
  3. Add --disable-elf-hack to configure options, as the error message suggests (this might removes some size/performance optimizations).

I'll try those options, in order, and report back.

Edit: OK, the first option works, the package successfully built and the program launches and doesn't crash. I suggest you add this patch.

Unfortunately, because of another package being "too new" (ffmpeg), some codecs don't work on e.g. youtube. I was hoping this just requires a fresh build, but nope. I'll try applying another patch from newer firefox versions (https://hg.mozilla.org/integration/autoland/rev/573a198b7fdf), I will report if I succeed.

Edit: OK, that did the trick. I only had to tweak the patch a bit. So, another suggestion, add the ffmpeg4 patch (bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1435212 commit: https://hg.mozilla.org/integration/autoland/rev/573a198b7fdf patch fixed for 56: http://sprunge.us/tL8cdX).

Here are the updated files:

Now, the only thing missing for me would be security patches. I'll try to get them later (or one could use Waterfox 56 I guess). Anything to avoid the "quantum" disaster as long as possible.

Splith commented on 2018-07-06 00:46

Patch and minor fixes added, thanks andrius4669

andrius4669 commented on 2018-06-07 18:34

https://bugzilla.mozilla.org/show_bug.cgi?id=1435695

andrius4669 commented on 2018-06-07 16:27

when building, got:

==> Starting prepare()...

mkdir: cannot create directory ‘path’: File exists

mkdir should have -p and later ln should have -f

Splith commented on 2018-03-23 06:21

That would be because partial upgrades are not supported per the wiki: https://wiki.archlinux.org/index.php/System_maintenance#Partial_upgrades_are_unsupported

I'm not going to go through and check every library to see what exact minimum versions are required for building, but alas for this one time I shall update it.

kaptoxic commented on 2018-03-23 05:35

I think you missed that I wrote "version constraint". Some systems might have older sqllite3 (like in my case) and on those the compilation will throw an error.

Splith commented on 2018-03-21 08:17

I've just done a test build up to Mach's compile stage and it's working fine. SQLite is already a package requirement so this looks to be a problem with your install or you've edited the package build file to remove this requirement.

kaptoxic commented on 2018-03-21 00:01

I got an error due to a missing version constraint: "configure: error: Library requirements (sqlite3 >= 3.19.3) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." Should be easy to add it.

Splith commented on 2018-01-06 22:48

Package has been fixed up and now compiles and runs. It would probably be possible to get this to run alongside firefox 57 but I'm not going to put any time/effort into that, I want this as a dropin replacement on my systems, firefox 57 screws with and messes up the firefox 56 UI so if you want to have 56 and 57 side-by-side you will need to create your own package and submit it to the AUR.