Package Details: firefox-nightly-i18n-hy-am 82.0a1.20200826-1

Git Clone URL: https://aur.archlinux.org/firefox-nightly-i18n.git (read-only, click to copy)
Package Base: firefox-nightly-i18n
Description: Language pack for Firefox Nightly
Upstream URL: https://www.mozilla.org/firefox/
Keywords: i18n
Licenses: GPL, MPL, LGPL
Provides: firefox-nightly-i18n=82.0a1.20200826-1
Submitter: swiftgeek
Maintainer: Anthony25
Last Packager: TheGoliath
Votes: 8
Popularity: 0.66
First Submitted: 2013-08-30 23:16
Last Updated: 2020-09-14 12:02

Required by (0)

Sources (95)

Pinned Comments

swiftgeek commented on 2015-04-01 03:55

If somebody has no idea what this package does - it grabs language packs in xpi form from mozilla ftp, matching to uncommented entries from /etc/locale.gen

Available LANG-packs on the server (as of today, this is automagically found out on the server): ar ast cs de en-GB eo es-AR es-CL es-ES es-MX fa fr fy-NL gl he hu id it ja-JP-mac ja kk ko lt lv nb-NO nl nn-NO oc pl pt-BR pt-PT ru sk sl sv-SE th tr uk vi zh-CN zh-TW ar ast cs de en-GB eo es-AR es-CL es-ES es-MX fa fr fy-NL gl he hu id it ja-JP-mac ja kk ko lt lv nb-NO nl nn-NO oc pl pt-BR pt-PT ru sk sl sv-SE th tr uk vi zh-CN zh-TW

Before installing you should set extensions.autoDisableScopes to 11 (just like the stable has by default - but nightly doesn't). Sadly i cannot add this as a vendor pref without a lockPref due to unknown bug ( http://kb.mozillazine.org/Lock_Prefs , http://mike.kaply.com/2012/02/09/integrating-add-ons-into-firefox/ , https://bugzilla.mozilla.org/show_bug.cgi?id=779437 )

Latest Comments

1 2 Next › Last »

jwtiyar commented on 2020-09-29 15:06

Hey Can you please add ckb packagw also? because already avaialable from firefox for nightly build.

gardenappl commented on 2020-05-15 12:20

I'm also getting a (different) error:

==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version:   -> Installed firefox-nightly is newer than 64.0a1. Bumping to 78.0a1.20200514-1
78.0a1.20200514

DAC324 commented on 2020-03-23 08:17

This package seems to have an error somewhere (can't install):

==> Making package: firefox-nightly-i18n 64.0a1.20180916-1 (Mon Mar 23 09:15:54 2020)
==> Retrieving sources...
==> Making package: firefox-nightly-i18n 64.0a1.20180916-1 (Mon Mar 23 09:15:55 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Starting pkgver()...
sed: can't read /var/lib/pacman/local/firefox-nightly-??.?a?.????????-*/desc: No such file or directory
==> ERROR: A failure occurred in pkgver().
    Aborting...
Error making: firefox-nightly-i18n
Also, it looks like the package as such needs an update: Version is still
64.0a1.20180916-1
while latest Firefox nightly package from AUR has
76.0a1.20200322.23-1
.

swiftgeek commented on 2018-09-16 16:07

@eschwartz: Simple sed command is far from being "database parser" and it's much more efficient than running pacman for such trivial information

eschwartz commented on 2018-09-16 15:12

Why did you write a custom libalpm database parser instead of using:

pacman -Q firefox-nightly| cut -d' ' -f2

swiftgeek commented on 2015-06-07 11:23

Package still works fine, it will now even bump itself provided that installed firefox-nightly is newer than this PKGBUILD.

Automatic language selection via intl.locale.matchOS is broken since 59.x as reported by some ubuntu user: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1755918 and intl.locale.requested has to be used instead (with value of chosen locale like ru)

airon90 commented on 2015-06-07 10:18

It seems not working.

[airon@aironpc ~]$ pacaur -Syu

[CUT]

:: Starting AUR upgrade...
:: resolving dependencies...
:: looking for inter-conflicts...
:: firefox-nightly-i18n latest revision -- fetching

AUR Packages (1): firefox-nightly-i18n-latest

:: Proceed with installation? [Y/n]

:: Retrieving package(s)...
:: View firefox-nightly-i18n PKGBUILD? [Y/n] n
:: Checking firefox-nightly-i18n integrity...
==> Making package: firefox-nightly-i18n 41.0a1.20141205-1 (Sun Jun 7 12:17:19 CEST 2015)
==> Retrieving sources...
:: Building firefox-nightly-i18n package(s)...
==> Making package: firefox-nightly-i18n 40.0a1.20150607-1 (Sun Jun 7 12:17:19 CEST 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> Extracting sources...
==> Starting pkgver()...
==> Starting prepare()...
==> Getting LANG-packs list from ftp.mozilla.com…
-> Available LANG-packs on the server: ar he pl
-> Detected LANGs: en-US it-IT
==> WARNING: en-US was not found on the server - removing
==> WARNING: it-IT was not found on the server - removing
==> Matched LANGs:
:: firefox-nightly-i18n cleaning skipped
:: failed to build firefox-nightly-i18n package(s)

swiftgeek commented on 2015-04-01 03:55

If somebody has no idea what this package does - it grabs language packs in xpi form from mozilla ftp, matching to uncommented entries from /etc/locale.gen

Available LANG-packs on the server (as of today, this is automagically found out on the server): ar ast cs de en-GB eo es-AR es-CL es-ES es-MX fa fr fy-NL gl he hu id it ja-JP-mac ja kk ko lt lv nb-NO nl nn-NO oc pl pt-BR pt-PT ru sk sl sv-SE th tr uk vi zh-CN zh-TW ar ast cs de en-GB eo es-AR es-CL es-ES es-MX fa fr fy-NL gl he hu id it ja-JP-mac ja kk ko lt lv nb-NO nl nn-NO oc pl pt-BR pt-PT ru sk sl sv-SE th tr uk vi zh-CN zh-TW

Before installing you should set extensions.autoDisableScopes to 11 (just like the stable has by default - but nightly doesn't). Sadly i cannot add this as a vendor pref without a lockPref due to unknown bug ( http://kb.mozillazine.org/Lock_Prefs , http://mike.kaply.com/2012/02/09/integrating-add-ons-into-firefox/ , https://bugzilla.mozilla.org/show_bug.cgi?id=779437 )

swiftgeek commented on 2013-10-30 01:26

TODO: Find dictionaries on the ftp server

swiftgeek commented on 2013-09-07 08:05

The only way i have managed to set extensions.autoDisableScopes to 11 from global configfile was via lockPref
http://kb.mozillazine.org/Lock_Prefs