Package Details: firefox-kde-opensuse 68.0.2-1

Git Clone URL: https://aur.archlinux.org/firefox-kde-opensuse.git (read-only)
Package Base: firefox-kde-opensuse
Description: Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
Upstream URL: https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
Keywords: browser gecko web
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox=68.0.2
Submitter: csslayer
Maintainer: Thaodan
Last Packager: Thaodan
Votes: 316
Popularity: 4.270650
First Submitted: 2009-12-11 09:10
Last Updated: 2019-08-16 08:17

Dependencies (48)

Required by (219)

Sources (19)

Pinned Comments

Thaodan commented on 2018-07-11 18:15

upstream git repo:* (https://gitlab.com/Thaodan/firefox-kde-opensuse)

repo in /etc/pacman.conf:

[home-thaodan]
Server = https://thaodan.de/public/archlinux/home-thaodan/x86_64/

import the key

sudo pacman-key --recv-keys BBFE2FD421597395E4FC8C8DF6C85FEE79D661A4
pacman-key --finger BBFE2FD421597395E4FC8C8DF6C85FEE79D661A4
sudo pacman-key --lsign-key  BBFE2FD421597395E4FC8C8DF6C85FEE79D661A4
sudo pacman-key --refresh-keys

fingerprint:

gpg: enabled debug flags: memstat
gpg: keydb: handles=1 locks=0 parse=0 get=1
gpg:        build=0 update=0 insert=0 delete=0
gpg:        reset=0 found=1 not=1 cache=0 not=0
gpg: kid_not_found_cache: count=0 peak=0 flushes=0
gpg: sig_cache: total=2 cached=2 good=2 bad=0
gpg: random usage: poolsize=600 mixed=0 polls=0/0 added=0/0
           outmix=0 getlvl1=0/0 getlvl2=0/0
gpg: rndjent stat: collector=0x0000000000000000 calls=0 bytes=0
gpg: secmem usage: 0/32768 bytes in 0 blocks
pub   rsa2048 2015-02-13 [SC]
       BBFE 2FD4 2159 7395 E4FC  8C8D F6C8 5FEE 79D6 61A4
uid        [ ultimativ ] Björn Bidar <theodorstormgrade@gmail.com>
sub   rsa2048 2015-02-13 [E]

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

XavierCLL commented on 2018-07-11 05:06

Confirmed the problem with spellchecker, @Thaodan please apply some changes implemented in the official packages to solving it: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/firefox&id=95dd034eb8ae4263b371b074a57762eead705f96

francoism90 commented on 2018-07-09 19:30

@Thaodan After upgrading (using repo) the spellchecker isn't work and the addons were removed out of the interface. Can you confirm?

francoism90 commented on 2018-06-28 07:12

@Thaodan I'm using the repo one, but I think it has been solved. It seems the cause was pulseaudio - it stopped working after an upgrade. I have removed and reinstalled pulse and now it works fine. :)

What was a bit weird is that firefox-developer-edition worked without any issues, maybe something changed upstream in the next version of FF.

Anyway, glad it's works fine now thanks. (Y)

Thaodan commented on 2018-06-27 19:07

PLease be more verbose, which build mine or self build?

francoism90 commented on 2018-06-27 07:56

@XavierCLL It may be needed to run sudo pacman-key --refresh-keys prior importing the keys.

Mel commented on 2018-06-09 10:46

I didn't have it installed and build errored out. Vanilla firefox package in arch repos has it in makedepends: makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb autoconf2.13 rust mercurial clang llvm jack gtk2) Manually installed it and build proceeded.

Edit: Here's the error, I was able to reproduce it without clang installed:

==> Starting build()...
 0:00.34 Clobber not needed.
 0:00.34 Adding make options from /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/.mozconfig
    PROFILE_GEN_SCRIPT=EXTRA_TEST_ARGS=10 $(MAKE) -C $(MOZ_OBJDIR) pgo-profile-run
    MOZ_OBJDIR=/home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/obj-x86_64-pc-linux-gnu
    OBJDIR=/home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/obj-x86_64-pc-linux-gnu
    FOUND_MOZCONFIG=/home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/.mozconfig
    export FOUND_MOZCONFIG
 0:00.35 /usr/bin/make -f client.mk -s configure
 0:00.36 Generating /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/configure
 0:00.36 Generating /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/js/src/configure
 0:00.37 cd /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/obj-x86_64-pc-linux-gnu
 0:00.37 /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/configure
 0:00.46 Creating Python environment
 0:01.41 New python executable in /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/obj-x86_64-pc-linux-gnu/_virtualenv/bin/python2
 0:01.41 Also creating executable in /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/obj-x86_64-pc-linux-gnu/_virtualenv/bin/python
 0:01.41 Installing setuptools, pip, wheel...done.
 0:02.11 running build_ext
 0:02.11 building 'psutil._psutil_linux' extension
 0:02.11 creating build
 0:02.11 creating build/temp.linux-x86_64-2.7
 0:02.11 creating build/temp.linux-x86_64-2.7/psutil
 0:02.11 gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -O2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
 0:02.11 gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -O2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
 0:02.11 gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -O2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_linux.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o
 0:02.11 creating build/lib.linux-x86_64-2.7
 0:02.11 creating build/lib.linux-x86_64-2.7/psutil
 0:02.11 gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -D_FORTIFY_SOURCE=2 -O2 build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o -L/usr/lib -lpython2.7 -o build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so
 0:02.11 building 'psutil._psutil_posix' extension
 0:02.11 gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -O2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
 0:02.11 gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -O2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
 0:02.11 gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -D_FORTIFY_SOURCE=2 -O2 build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o -L/usr/lib -lpython2.7 -o build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so
 0:02.11 copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
 0:02.11 copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
 0:02.11 
 0:02.11 Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
 0:02.11 Reexecuting in the virtualenv
 0:02.23 Adding configure options from /home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/.mozconfig
 0:02.23   --enable-application=browser
 0:02.23   --prefix=/usr
 0:02.23   --enable-gold
 0:02.23   --enable-pie
 0:02.23   --enable-optimize=-O2
 0:02.23   --enable-rust-simd
 0:02.23   --enable-release
 0:02.23   --enable-official-branding
 0:02.23   --enable-update-channel=release
 0:02.23   --with-distribution-id=org.archlinux
 0:02.23   --with-system-nspr
 0:02.23   --with-system-nss
 0:02.23   --with-system-icu
 0:02.23   --with-system-jpeg
 0:02.23   --with-system-zlib
 0:02.23   --with-system-bz2
 0:02.23   --with-system-libvpx
 0:02.23   --with-system-harfbuzz
 0:02.23   --with-system-graphite2
 0:02.23   --enable-system-hunspell
 0:02.23   --enable-system-sqlite
 0:02.23   --enable-system-ffi
 0:02.23   --enable-system-pixman
 0:02.23   --disable-libproxy
 0:02.23   --enable-jack
 0:02.23   --enable-alsa
 0:02.23   --enable-startup-notification
 0:02.23   --enable-crashreporter
 0:02.23   --disable-updater
 0:02.23   --disable-gconf
 0:02.23   --disable-tests
 0:02.23   --with-google-api-keyfile=/home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/google-api-key
 0:02.23   --with-google-api-keyfile=/home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/google-oauth-api-key
 0:02.23   --with-mozilla-api-keyfile=/home/anon/.cache/aursync/firefox-kde-opensuse/src/mozilla-unified/mozilla-api-key
 0:02.23   MOZILLA_OFFICIAL=1
 0:02.23   MOZ_ADDON_SIGNING=1
 0:02.23   MOZ_REQUIRE_SIGNING=1
 0:02.23   BUILD_OFFICIAL=1
 0:02.23   MOZ_TELEMETRY_REPORTING=1
 0:02.23 checking for vcs source checkout... hg
 0:02.37 checking for a shell... /usr/bin/sh
 0:02.42 checking for host system type... x86_64-pc-linux-gnu
 0:02.42 checking for target system type... x86_64-pc-linux-gnu
 0:02.46 checking for a shell... /usr/bin/sh
 0:02.50 checking for host system type... x86_64-pc-linux-gnu
 0:02.50 checking for target system type... x86_64-pc-linux-gnu
 0:02.56 checking for vcs source checkout... hg
 0:02.56 checking whether cross compiling... no
 0:02.56 checking for the target C compiler... /usr/bin/gcc
 0:02.58 checking whether the target C compiler can be used... yes
 0:02.60 checking for Python 3... /usr/bin/python3 (3.6.5)
 0:02.61 checking for hg... /usr/bin/hg
 0:02.65 checking for Mercurial version... 4.6.1
 0:02.71 checking for sparse checkout... no
 0:02.71 checking for pkg_config... /usr/bin/pkg-config
 0:02.72 checking for pkg-config version... 1.4.2
 0:02.72 checking for yasm... /usr/bin/yasm
 0:02.73 checking yasm version... 1.3.0
 0:02.73 checking the target C compiler version... 8.1.1
 0:02.75 checking the target C compiler works... yes
 0:02.75 checking for the target C++ compiler... /usr/bin/g++
 0:02.76 checking whether the target C++ compiler can be used... yes
 0:02.76 checking the target C++ compiler version... 8.1.1
 0:02.78 checking the target C++ compiler works... yes
 0:02.78 checking for the host C compiler... /usr/bin/gcc
 0:02.79 checking whether the host C compiler can be used... yes
 0:02.79 checking the host C compiler version... 8.1.1
 0:02.80 checking the host C compiler works... yes
 0:02.80 checking for the host C++ compiler... /usr/bin/g++
 0:02.82 checking whether the host C++ compiler can be used... yes
 0:02.82 checking the host C++ compiler version... 8.1.1
 0:02.83 checking the host C++ compiler works... yes
 0:02.85 checking for 64-bit OS... yes
 0:02.85 checking bindgen cflags... no
 0:02.86 checking for linker... gold
 0:02.88 checking for stdint.h... yes
 0:02.90 checking for inttypes.h... yes
 0:02.92 checking for malloc.h... yes
 0:02.94 checking for alloca.h... yes
 0:02.95 checking for sys/byteorder.h... no
 0:02.97 checking for getopt.h... yes
 0:02.99 checking for unistd.h... yes
 0:03.01 checking for nl_types.h... yes
 0:03.03 checking for cpuid.h... yes
 0:03.04 checking for sys/statvfs.h... yes
 0:03.06 checking for sys/statfs.h... yes
 0:03.08 checking for sys/vfs.h... yes
 0:03.10 checking for sys/mount.h... yes
 0:03.12 checking for sys/quota.h... yes
 0:03.14 checking for linux/quota.h... yes
 0:03.17 checking for linux/if_addr.h... yes
 0:03.19 checking for linux/rtnetlink.h... yes
 0:03.21 checking for sys/queue.h... yes
 0:03.23 checking for sys/types.h... yes
 0:03.25 checking for netinet/in.h... yes
 0:03.27 checking for byteswap.h... yes
 0:03.29 checking for linux/perf_event.h... yes
 0:03.30 checking for perf_event_open system call... yes
 0:03.32 checking whether the C compiler supports -Wunreachable-code-return... no
 0:03.33 checking whether the C++ compiler supports -Wunreachable-code-return... no
 0:03.34 checking whether the C compiler supports -Wclass-varargs... no
 0:03.34 checking whether the C++ compiler supports -Wclass-varargs... no
 0:03.35 checking whether the C compiler supports -Wloop-analysis... no
 0:03.35 checking whether the C++ compiler supports -Wloop-analysis... no
 0:03.37 checking whether the C++ compiler supports -Wc++1z-compat... yes
 0:03.38 checking whether the C++ compiler supports -Wcomma... no
 0:03.39 checking whether the C compiler supports -Wduplicated-cond... yes
 0:03.41 checking whether the C++ compiler supports -Wduplicated-cond... yes
 0:03.43 checking whether the C++ compiler supports -Wimplicit-fallthrough... yes
 0:03.44 checking whether the C compiler supports -Wstring-conversion... no
 0:03.44 checking whether the C++ compiler supports -Wstring-conversion... no
 0:03.45 checking whether the C++ compiler supports -Wno-inline-new-delete... no
 0:03.47 checking whether the C compiler supports -Wno-error=maybe-uninitialized... yes
 0:03.49 checking whether the C++ compiler supports -Wno-error=maybe-uninitialized... yes
 0:03.50 checking whether the C compiler supports -Wno-error=deprecated-declarations... yes
 0:03.52 checking whether the C++ compiler supports -Wno-error=deprecated-declarations... yes
 0:03.53 checking whether the C compiler supports -Wno-error=array-bounds... yes
 0:03.55 checking whether the C++ compiler supports -Wno-error=array-bounds... yes
 0:03.57 checking whether the C compiler supports -Wno-error=free-nonheap-object... yes
 0:03.58 checking whether the C++ compiler supports -Wno-error=free-nonheap-object... yes
 0:03.60 checking whether the C compiler supports -Wformat... yes
 0:03.62 checking whether the C++ compiler supports -Wformat... yes
 0:03.63 checking whether the C compiler supports -Wformat-security... no
 0:03.65 checking whether the C++ compiler supports -Wformat-security... no
 0:03.66 checking whether the C compiler supports -Wformat-overflow=2... yes
 0:03.68 checking whether the C++ compiler supports -Wformat-overflow=2... yes
 0:03.69 checking whether the C compiler supports -Wno-gnu-zero-variadic-macro-arguments... no
 0:03.71 checking whether the C++ compiler supports -Wno-gnu-zero-variadic-macro-arguments... no
 0:03.72 checking whether the C++ compiler supports -fno-sized-deallocation... yes
 0:03.73 checking for libffi > 3.0.9... yes
 0:03.73 checking MOZ_FFI_CFLAGS... -I/usr/lib/libffi-3.2.1/include
 0:03.74 checking MOZ_FFI_LIBS... -L/usr/lib/../lib -lffi
 0:03.74 checking for rustc... /usr/bin/rustc
 0:03.74 checking for cargo... /usr/bin/cargo
 0:03.80 checking rustc version... 1.26.2
 0:03.82 checking cargo version... 1.26.0
 0:03.97 checking for pango >= 1.22.0 pangoft2 >= 1.22.0 pangocairo >= 1.22.0... yes
 0:03.98 checking MOZ_PANGO_CFLAGS... -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/uuid -I/usr/include/cairo -I/usr/include/pixman-1
 0:03.99 checking MOZ_PANGO_LIBS... -lpangoft2-1.0 -lfontconfig -lfreetype -lpangocairo-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfribidi -lcairo
 0:03.99 checking for fontconfig >= 2.7.0... yes
 0:04.00 checking _FONTCONFIG_CFLAGS... -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/uuid
 0:04.00 checking _FONTCONFIG_LIBS... -lfontconfig -lfreetype
 0:04.01 checking for freetype2 >= 6.1.0... yes
 0:04.01 checking _FT2_CFLAGS... -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
 0:04.01 checking _FT2_LIBS... -lfreetype
 0:04.02 checking for graphite2... yes
 0:04.02 checking MOZ_GRAPHITE2_CFLAGS...
 0:04.03 checking MOZ_GRAPHITE2_LIBS... -lgraphite2
 0:04.03 checking for harfbuzz >= 1.4.2... yes
 0:04.04 checking MOZ_HARFBUZZ_CFLAGS... -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
 0:04.04 checking MOZ_HARFBUZZ_LIBS... -lharfbuzz
 0:04.04 checking for tar... /usr/bin/tar
 0:04.04 checking for unzip... /usr/bin/unzip
 0:04.04 checking for zip... /usr/bin/zip
 0:04.04 checking for gn... not found
 0:04.04 checking for the Mozilla API key... yes
 0:04.04 checking for the Google API key... yes
 0:04.04 checking for the Bing API key... no
 0:04.04 checking for the Adjust SDK key... no
 0:04.04 checking for the Leanplum SDK key... no
 0:04.04 checking for the Pocket API key... no
 0:04.04 checking for llvm-config... /usr/bin/llvm-config
 0:04.09 ERROR: The file /usr/bin/clang returned by `llvm-config --bindir` does not exist.
 0:04.09 clang is required to build Stylo.  Please install the necessary packages,
 0:04.09 run `mach bootstrap`, or add --disable-stylo to your mozconfig.
 0:04.09 
 0:04.11 *** Fix above errors and then restart with\
 0:04.11                "/usr/bin/make -f client.mk build"
 0:04.11 make: *** [client.mk:149: configure] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

Thaodan commented on 2018-06-09 10:25

Why?

Mel commented on 2018-06-09 10:25

Could you please include 'clang' in makedepends array?

Thaodan commented on 2018-05-27 17:46

Please check your build environment first! Try my build posted below olr try a clean chroot.

gfurst commented on 2018-05-27 17:17

I'm also having the same issue below, version 60.0 fails to open with the crash reporter everytime, however with fewer verbosity. Had to reverse back to 59 for the time being.

First thing to check is if for most people it does indeed work in this version, or else, check if "vanilla" firefox 60 does indeed work as well. May be some severe bug from upstream.