Package Details: firefox-extension-google-search-link-fix 1.6.10-3

Git Clone URL: https://aur.archlinux.org/firefox-extension-google-search-link-fix.git (read-only, click to copy)
Package Base: firefox-extension-google-search-link-fix
Description: Prevents Google and Yandex search pages from modifying search result links when you click them
Upstream URL: https://github.com/palant/searchlinkfix
Licenses: MPL2
Groups: firefox-addons
Submitter: cameel
Maintainer: cameel
Last Packager: cameel
Votes: 3
Popularity: 0.000641
First Submitted: 2018-01-27 12:15
Last Updated: 2021-05-09 21:41

Latest Comments

cameel commented on 2021-05-09 21:38

Hi @risto3. I have uploaded a rewritten PKGBUILD yesterday and now the addon gets built from source. The problem you're seeing is most likely because you're using an old version of nodejs. The homepage of the addon states that at least 13.8.0 is required to build it. I checked, and it works with nodejs-lts-erbium (version 12) from community. I only managed to reproduce your problem with nodejs-lts-dubnium (version 10).

I have added the minimum dependency version to the PKGBUILD so that now it produces an error that it's more self-explanatory but I can't really make it work with nodejs 10 if the author does not support it. This version is already EOL and the easiest solution would be to update to a newer one (it's currently at version 16 but 14 and 12 are also in community).

In case you can't update for some reason, here's the last version of the PKGBUILD from before the rewrite. You could install from that or even upload it to AUR as a -bin version of the package (i.e. firefox-extension-google-search-link-fix-bin).

risto3 commented on 2021-05-09 13:46

Can't build this any more:

  -> Extracting searchlinkfix-1.6.10.tar.gz with bsdtar
==> Starting build()...
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.

added 634 packages, and audited 635 packages in 1m

35 packages are looking for funding
  run `npm fund` for details

5 low severity vulnerabilities

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.
/tmp/makepkg/firefox-extension-google-search-link-fix/src/searchlinkfix-1.6.10/gulpfile.js:9
import fs from "fs";
       ^^

SyntaxError: Unexpected identifier
    at Module._compile (internal/modules/cjs/loader.js:723:23)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    at Function.Module._load (internal/modules/cjs/loader.js:585:3)
    at Module.require (internal/modules/cjs/loader.js:692:17)
    at require (internal/modules/cjs/helpers.js:25:18)
    at requireOrImport (/tmp/makepkg/firefox-extension-google-search-link-fix/src/searchlinkfix-1.6.10/node_modules/gulp-cli/lib/shared/require-or-import.js:19:11)
    at execute (/tmp/makepkg/firefox-extension-google-search-link-fix/src/searchlinkfix-1.6.10/node_modules/gulp-cli/lib/versioned/^4.0.0/index.js:37:3)
    at Liftoff.handleArguments (/tmp/makepkg/firefox-extension-google-search-link-fix/src/searchlinkfix-1.6.10/node_modules/gulp-cli/index.js:211:24)
==> ERROR: A failure occurred in build().
    Aborting...