Package Details: firefox-extension-bitwarden 1.50.0-3

Git Clone URL: https://aur.archlinux.org/firefox-extension-bitwarden.git (read-only, click to copy)
Package Base: firefox-extension-bitwarden
Description: Bitwarden addon for Firefox
Upstream URL: https://addons.mozilla.org/en-US/firefox/addon/bitwarden-password-manager/
Licenses: GPLv3
Groups: firefox-addons
Submitter: librewish
Maintainer: defusq
Last Packager: defusq
Votes: 2
Popularity: 0.40
First Submitted: 2020-09-25 16:48
Last Updated: 2021-06-29 21:08

Latest Comments

wsppan commented on 2021-06-29 13:24

I removed extension.xpi from my cache dir and tried again successfully.

rm .cache/yay/firefox-extension-bitwarden/extension.xpi

==> Validating source files with sha512sums... extension.xpi ... Passed

defusq commented on 2021-06-29 13:14

That's strange, I just tried it and it seems to work fine for me. It looks like Mozilla is serving different copies from the same URL?

wsppan commented on 2021-06-29 13:04

I get the following trying to upgrade to the latest version:

:: Searching AUR for updates... -> Flagged Out Of Date AUR Packages: eclipse-java resvg vivaldi-codecs-ffmpeg-extra-bin vizex :: 1 Packages to upgrade. 1 aur/firefox-extension-bitwarden 1.48.1-1 -> 1.50.0-2 ==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name) ==> :: Checking for conflicts... :: Checking for inner conflicts... [Aur:1] firefox-extension-bitwarden-1.50.0-2

1 firefox-extension-bitwarden (Installed) (Build Files Exist) ==> Packages to cleanBuild? ==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4) ==> :: PKGBUILD up to date, Skipping (1/1): firefox-extension-bitwarden 1 firefox-extension-bitwarden (Installed) (Build Files Exist) ==> Diffs to show? ==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4) ==> :: (1/1) Parsing SRCINFO: firefox-extension-bitwarden ==> Making package: firefox-extension-bitwarden 1.50.0-2 (Tue 29 Jun 2021 07:55:36 AM CDT) ==> Retrieving sources... -> Found extension.xpi ==> Validating source files with sha512sums... extension.xpi ... FAILED ==> ERROR: One or more files did not pass the validity check! error downloading sources: firefox-extension-bitwarden

defusq commented on 2021-06-27 21:31

Hi, sorry about that - should be fixed now!

juxuanu commented on 2021-06-27 21:21

Hello, I am installing this extension and when I check the version on the extension https://imgur.com/WmxXbfW which I confirm is quite old since it doesn't have the "Send" functionality recently added.

dhummel commented on 2021-06-16 20:32

Awesome, there's a new-new version out today (v1.50.0):
diff --git a/PKGBUILD b/PKGBUILD
index 157d581..6695aee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=firefox-extension-bitwarden
-pkgver=1.48.1
+pkgver=1.50.0
 pkgrel=1
 pkgdesc='bitwarden addon for firefox.'
 arch=('any')
@@ -7,8 +7,8 @@ url='https://addons.mozilla.org/en-US/firefox/addon/bitwarden-password-manager/'
 license=('GPLV3')
 depends=('firefox')
 groups=('firefox-addons')
-source=("extension.xpi::https://addons.mozilla.org/firefox/downloads/file/3643785/bitwarden_free_password_manager-${pkgver}-an+fx.xpi")
-sha512sums=('8759626d0b1e5647e58024d9ca74253cdcc6cb45f998a9a71406c562045c8279b1a84574042a22ec564be211b167cef66e1d78148164f897bd7aadb02b4d73be')
+source=("extension.xpi::https://addons.mozilla.org/firefox/downloads/file/3775487/bitwarden_free_password_manager-${pkgver}-an+fx.xpi")
+sha512sums=('2406ea4e3791340649a17ac4c47f1b03212cf68f83a2fa70c772f8634faadf1ffe59d302bfc0b86bf4336502aed504de62e1fdc3d816bad6814f03bbcf26c6ee')

 package() {
   install -Dm644 extension.xpi "${pkgdir}/usr/lib/firefox/browser/extensions/{446900e4-71c2-419f-a6a7-df9c091e268b}.xpi"