Package Details: firefox-dpms-git r19.d042b6a-1

Git Clone URL: https://aur.archlinux.org/firefox-dpms-git.git (read-only, click to copy)
Package Base: firefox-dpms-git
Description: Disable DPMS settings when playing video in Firefox
Upstream URL: https://github.com/dglava/firefox-dpms
Licenses: GPL3
Submitter: justasug
Maintainer: justasug
Last Packager: justasug
Votes: 1
Popularity: 0.000000
First Submitted: 2018-02-01 10:23
Last Updated: 2021-01-25 13:54

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

justasug commented on 2021-01-25 13:56

I have changed the dependency to the other (correctly named) python-pulsectl package.

yochananmarqos commented on 2021-01-24 15:30

@justasug: The Python module is called pulsectl and that's what is required. See the setup.py.

C0rn3j commented on 2021-01-24 14:53

https://wiki.archlinux.org/index.php/Python_package_guidelines

I think the best practice in this situation would be to switch to the 'new' pulsectl unless your package specifically needs the git version, which is still pulse-control for the time being.

justasug commented on 2021-01-24 14:27

@C0rn3j Why is that package called python-pulsectl? On the upstream page it's called python-pulse-control, but on pypi it's called pulsectl. There's no "provides" in the package. I don't know which one is the correct one (in regards to the name). Is there a "best practices" guide for such a situation?

C0rn3j commented on 2021-01-22 23:48

python-pulse-control was just merged into python-pulsectl, you may want to update the dependency

yochananmarqos commented on 2021-01-21 00:47

@justsasug: Oh, I see. I believe you are correct.

justasug commented on 2021-01-21 00:15

I used distutils from the standard library, not the setuptools library. I've looked at the documentation for the newest Python version and apparently one should switch to setuptools. But since it works without it, I didn't add it back. Should it be added back even though it works with distutils from the standard library?

yochananmarqos commented on 2021-01-20 15:10

@justasug: Yes, that works. Why did you remove python-setuptools from makedepends()? The setup.py calls it.

justasug commented on 2021-01-20 09:31

I have updated the PKGBUILD with the generated pkgver. Does this work?

Either way, you probably shouldn't use this this anymore as mentioned in the README. I'm leaving it up for archival purposes I guess.

yochananmarqos commented on 2021-01-17 17:21

@justasug: You're misunderstanding. As @aufkrawall originally mentioned, AUR helpers think there's any update with your imaginary 1-1 pkgver that never should have been there to begin with. You should have generated the pkgver before the initial commit as per VCS package guidelines.