Package Details: firefox-beta 70.0b14-1

Git Clone URL: https://aur.archlinux.org/firefox-beta.git (read-only)
Package Base: firefox-beta
Description: Standalone web browser from mozilla.org - Beta
Upstream URL: https://www.mozilla.org/en-US/firefox/channel/#beta
Keywords: browser gecko web
Licenses: GPL, MPL, LGPL
Conflicts: firefox-beta-bin
Provides: firefox=70.0b14
Submitter: argymeg
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 13
Popularity: 0.000028
First Submitted: 2015-10-05 23:34
Last Updated: 2019-10-12 12:09

Dependencies (35)

Required by (189)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

boosterdev commented on 2017-04-12 13:16

requires testing repo to use and build. feel free to adopt updated package to 53.0b10

jnbek commented on 2017-03-20 15:07

I just don't have the time right now this pkgbuild demands. I am setting it loose. If no one picks it up when things calm down, I may reconsider maintainership.

pinophyta commented on 2016-10-24 12:15

The download URL is no longer working:
==> ERROR: Failure while downloading https://download-installer.cdn.mozilla.net/pub/firefox/candidates/49.0b10-candidates/build1/source/firefox-49.0b10.source.tar.xz

The latest beta I see available:
https://download-installer.cdn.mozilla.net/pub/firefox/candidates/50.0b9-candidates/build1/source/firefox-50.0b9.source.tar.xz

jnbek commented on 2016-09-07 13:59

@rakuu, sure, or email me the diff

raku-cat commented on 2016-09-07 05:00

I was able to get this to build, changed pkgbuild to use 49.0b10, and changed mozconfig to drop the three settings it decided weren't real, should I make a merge request or what?

davidmcinnis commented on 2016-07-28 20:08

Hi,

I get the following error before building even starts:

mozbuild.configure.options.InvalidOptionError: Unknown option: --libdir

-Dave

teateawhy commented on 2016-06-10 23:49

Fails to build.
../config/nsinstall -R system_wrappers ../dist
../config/nsinstall: cannot access system_wrappers: No such file or directory

jnbek commented on 2016-05-13 15:15

zOMFG!!! What a pain in the ass... this is building again, please note, I will only be checking on this pkg weekly for the time being. Just flag it out of date if I miss something.

argymeg commented on 2016-03-09 22:14

46.0 is about to enter beta, however I will soon and for an unforeseeable amount of time be lacking both the time and the decent hardware needed to maintain this. I'm disowning it now rather than later so nobody gets stuck on a non-stable version. I hope someone else who found it useful can pick it up.

mrlamud commented on 2016-02-09 14:24

@argymeg, @Det

Problem solved.
It's my bad not mention all errors at first.

################################################################
"configure:17967: checking for gtk+-3.0 >= 3.4.0 gtk+-unix-print-3.0 glib-2.0 gobject-2.0
configure: error: Library requirements (gtk+-3.0 >= 3.4.0 gtk+-unix-print-3.0 glib-2.0 gobject-2.0 ) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.............................................Package egl was not found in the pkg-config search path.
Perhaps you should add the directory containing `egl.pc'
to the PKG_CONFIG_PATH environment variable
Package 'egl', required by 'cairo', not found "
################################################################

Problems is not from PKG_CONFIG_PATH but from "Package 'egl", required by 'cairo' , not found".

I built my own mesa which -somehow- works without problems but missing something that caused "Package 'egl", required by 'cairo' , not found".

Installing mesa mesa-libgl from official repo solves this problem.


Big thanks for your help,